Ask Your Question
1

Lose sound every time there is a kernel update

asked 2017-12-22 07:31:46 -0600

drsoles gravatar image

I have Fedora 26 but ever since Fedora 24 I've had problems with my sound being lost every time there is a kernel upgrade. Is there a way to prevent the driver from changing every time I get a new kernel update? I have a GeForce 570 GTX PCI-e Video card. Most of the time I have to wait until there is an additional update to the Nividia drivers.

edit retag flag offensive close merge delete

Comments

What video driver are you using? I use proprietary, with dkms. I do NOT have to update drivers or have any sound problems with kernel updates, and I have run nothing but proprietary from day one, when I came to Fedora 24 and started learning linux. I can give you the exact steps I use, and see if that helps, if you want.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-22 23:10:28 -0600 )edit

If the problem is sound, why do you mention the video card? You should check the sound card with lspci | grep -i audio.

fedelibre gravatar imagefedelibre ( 2017-12-23 02:52:14 -0600 )edit

hdmi carries sound. I assumed that was the issue, since the kernel drivers are changing when he gets a new kernel and the video driver is not being rebuilt properly, or he is using nouveau. his statement about waiting for nvidia driver updates, leads me to believe he is using an rpm and having to wait for repackaging to update for the new kernels. That is why I mentioned dkms, I NEVER have to wait on rpm packagers to update.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-23 09:35:49 -0600 )edit

My sound go through the video card which is a GeForce GTX570 video card. I get the following output when I enter lspci | grep -i audio:

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04) 04:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)

It looks like it would be a lot easier to use proprietary drivers. How do you use proprietary drivers with dkms?

drsoles gravatar imagedrsoles ( 2017-12-25 15:53:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-12-26 15:20:16 -0600

SteveEbey73701 gravatar image

updated 2017-12-28 08:37:40 -0600

Click here and save the file.

start terminal

sudo -i
systemctl set-default multi-user.target 
reboot
login as root
dnf install kernel-devel-$(uname -r) gcc dkms acpid
bash /dirofsavedfile/NVIDIA-Linux-x86_64-387.34.run -Z

Accept license, say yes to DKMS and 32 bit library installation. If running in secure boot EFI, you will be possibly need to make a digital key. I do not fully understand that procedure, so I disabled secure boot in my bios and did not have to do that step.

systemctl set-default graphical.target
reboot
edit flag offensive delete link more

Comments

I'm running into problems when I enter the dracut line. It gives me the message:
cat: write error: Broken pipe

drsoles gravatar imagedrsoles ( 2017-12-27 10:48:32 -0600 )edit

you did run as root, by using the sudo -i command first?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-27 16:44:10 -0600 )edit

Yes, I tried sudo -i and also tried logging is as root (su command) and typing in the dracut line.

drsoles gravatar imagedrsoles ( 2017-12-27 22:00:47 -0600 )edit

then one other option, would be to put -Z (upper case) after the .run on the command line when you install the nvidia driver, and let it take care of blacklisting nouveau.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-28 08:36:42 -0600 )edit

I was able to successfully install the propriety drivers with the -Z option but don't have sound. Is it possible that 387.34 isn't compatible with my graphics card?

drsoles gravatar imagedrsoles ( 2017-12-29 07:15:09 -0600 )edit

Question Tools

Stats

Asked: 2017-12-22 07:31:46 -0600

Seen: 287 times

Last updated: Dec 28 '17