Ask Your Question
1

(SOLVED) Can't change file permissions in Fedora 27 XFCE live session

asked 2017-12-21 17:28:36 -0500

alpha0 gravatar image

updated 2017-12-22 16:18:53 -0500

I've recently been test-driving a live usb of Fedora 27 XFCE, and I noticed that attempting to change file permissions doesn't seem to work. I had an executable file I generated on another computer that I tried to run in the live session via terminal, but it wouldn't run because it was no longer executable on the live system. I attempted to use chmod u+x $FILE and chmod 744 $FILE, both with and without sudo, and even though chmod said it had changed permissions, when I used ls -l on the file, the executable flag remained unset. I also tried to change the file's permissions via gui, but none of the options stuck (the box for 'allow file to be executed' would unset itself when I clicked it, and the drop-down menus for the user/group/etc. permissions would reset themselves to their original selections). I tried setting SELinux to permissive mode, thinking that might be it, but that had no effect.

Is there any reason why this might be happening? Is it a consequence of using a live session as opposed to a full installation, or is there some issue with Fedora itself?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-12-21 18:29:05 -0500

sideburns gravatar image

Welcome to ask.fedora. That's a good question, and I may have the answer for you. Is the media that the file is on formatted as VFAT, or with a Linux filesystem, such as ext4? If it's VFAT, the you don't have an executable flag and can't set it. Try copying it to your home folder on the live system and see if you can make it executable there.

edit flag offensive delete link more

Comments

Thanks for the welcome. I copied the executable to my home folder and chmod worked there. The stick the file was on is formatted as FAT32, not VFAT, but would the effect be the same? Just out of curiosity, I tried directly chmod'ing the file from an installation of Linux Mint, and the same thing happened. Anyways, thank you for the suggestion; I'm glad this isn't a Fedora issue, though I'll have to keep this in mind when transferring executable files in the future.

alpha0 gravatar imagealpha0 ( 2017-12-22 16:18:26 -0500 )edit

FAT32 and VFAT is same thing.

villykruse gravatar imagevillykruse ( 2017-12-22 16:21:31 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-12-21 17:28:36 -0500

Seen: 440 times

Last updated: Dec 22 '17