Ask Your Question
1

kernel-4.14.5-300.fc27.x86_64 freezes on boot up Nouveau comes back

asked 2017-12-15 13:35:07 -0600

Rockclimber gravatar image

kernel-4.13.16-300.fc27.x8664 works kernel-4.14.3-300.fc27.x8664 freezes kernel-4.14.5-300.fc27.x86_64 freezes how can I black list it?

edit retag flag offensive close merge delete

Comments

you want to use nouveau? if so, then you may need to put a ticket in so they know it broke on the kernel in question. if not, try getting to your second console at ctrl-alt f2 and see if you can remove nouveau, and instel the nvidia driver. I run proprietary, with dkms updates on kernel upgrades, and have 387.34 running on 4.14.5 with no issues.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-15 16:11:27 -0600 )edit

No I am using Nvidia card and driver. when it locks up as soon as I see it load the Nouveau driver this doesn't happen on kernel-4.13.16-300.fc27.x8664 kernel I will try hitting F2 I hit F4 F3 F2 and F1 nothing happened i will see what happens when I hit just F2 hopefully its works .. Thank you

Rockclimber gravatar imageRockclimber ( 2017-12-15 20:02:49 -0600 )edit

Ok I tried just hitting F2 and no go... I love fedora I been using Linux for a long time and tried Fedora and change over fast. I hope I get this problem fixed or I will have to start all over again. Hope they fix it because the only kernel that works will be wiped out and my system will be dead if the new one doesn't work. I may not love Fedora too much and do something else I don't want to. Fedora rocks when it works right...

Rockclimber gravatar imageRockclimber ( 2017-12-15 20:21:15 -0600 )edit

not just f2 but Ctrl-Alt F2 to get to a tty console. You could also put nomodeset in your linux commandline in grub, by hitting e on the grub menu and modify the command line entry put nomodeset=0 in front of the word quiet on the command line, then use ctrl-x to start that grub. you will get a low resolution graphic desktop, and can then use a terminal window to do sudo dnf remove *nouveau* and then reinstall the nvidia driver. if you use the nvidia proprietary run file to install put -Z after the word run, and that forces nvidia to disable nouveau for you, once and for all.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-16 08:09:54 -0600 )edit

[root@localhost-localdomaininsane jack]# sudo dnf remove nouveau Error: Problem: The operation would result in removing the following protected packages: kernel-core

I tried the grub command line and no go....

Is there any way to remove the two last kernel updates and try to update again? or could it be me running a core duo 2.50 processor?

Rockclimber gravatar imageRockclimber ( 2017-12-17 12:59:34 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-12-18 09:21:09 -0600

Rockclimber gravatar image

updated 2017-12-18 20:06:15 -0600

Solved Download your Nvidia driver hit Ctrl-Alt F2 to get to a tty console log on as Super User su, enter password, this was not easy because the TTY console was blinking so entering the password was a timing thing for me it may take a few mins. Install the downloaded Nvidia driver. That's it. I am Happy again! I just updated to 300.6 no problem.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-12-15 13:35:07 -0600

Seen: 359 times

Last updated: Dec 18 '17