Failed f26 -> f27 upgrade

asked 2017-12-12 11:26:10 -0600

Hi, I tried to upgrade from f26 to f27 in a hyper-v virtual machine. I followed the instructions to upgrade from command line, but something failed and this resulted in a system working but with mixed packages.

When I try to enforce upgrade again using:

 dnf system-upgrade download --releasever=27

I obtain:

Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y Last metadata expiration check: 0:00:00 ago on Tue 12 Dec 2017 18:15:27 CET. Error: Problem: The operation would result in removing the following protected packages: systemd, systemd-udev

I would like to complete upgrade. Any suggestion?

edit retag flag offensive close merge delete

Comments

What is the output of the following commands?

rpm -q fedora-release

rpm -q systemd

ssieb gravatar imagessieb ( 2017-12-12 13:55:44 -0600 )edit