Ask Your Question
0

Installing zlib 1.2.9 on fedora 26

asked 2017-12-01 14:58:07 -0500

Barros gravatar image

I have update fedora from 25 to 26, and since then I am having problems installing Ansys 18.1, that requires zlib 1.2.9 (apparently it doesn't recognize zlib 1.2.11). I wanted to install the onder version, but I am afraid that this will break the system. How can I safely install zlib 1.2.9 without having to uninstall the newer version?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-12-02 11:18:58 -0500

villykruse gravatar image

The zlib 1.2.9 and zlib 1.2.11 both provides libz.so.1 and that is the only thing that should really matter. I have no idea how Ansys apparently requires explicitly version 1.2.9, but that requirement is too specific.

edit flag offensive delete link more
0

answered 2017-12-02 13:20:14 -0500

fcomida gravatar image

You can try cd /usr/lib64; ln -s libz.so.1.2.11 libz.so.1.2.9

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-12-01 14:58:07 -0500

Seen: 364 times

Last updated: Dec 02 '17