Ask Your Question
1

Blender 3d will not launch in fedora 26

asked 2017-11-14 13:02:20 -0500

tamesu gravatar image

updated 2017-11-16 05:54:05 -0500

Hello

When i open blender in fedora 26, it says that it requires higher OpenGL. But with fedora 25 it works.

My PC iis not new, and i have intell internal graphics

Thank you

----- added:

This is from fedora 25 where latest blender does work, Would the info from fedora 26 be more helpful?

System: Host: dhcppc2 Kernel: 4.13.11-100.fc25.i686 i686 bits: 32 Desktop: Gnome 3.22.3 Distro: Fedora release 25 (Twenty Five) Graphics: Card: Intel 82G33/G31 Express Integrated Graphics Controller Display Server: x11 (X.org 119.3 ) driver: i915 Resolution: 1600x900@60.00hz OpenGL: renderer: Mesa DRI Intel G33 version: 2.1 Mesa 17.0.5

edit retag flag offensive close merge delete

Comments

Hi, look at this question https://ask.fedoraproject.org/en/ques...

ozeszty gravatar imageozeszty ( 2017-11-14 17:53:50 -0500 )edit

hello ozeszty, i looked at the question you referred to. But blender 2.78 does run on fedora 25. So does this mean my graphics has capabilities to run the required version of OpenGL? Then whats with fedora 26? Acturally, the blender does run on fedora 26, but it only starts showing the error after i uprade it (with dnf upgrade) (blender i don't install with rpm, i download the latest version from the blender website) Thank you

tamesu gravatar imagetamesu ( 2017-11-14 19:05:38 -0500 )edit

Edit your question and add to it inxi -SG output.

ozeszty gravatar imageozeszty ( 2017-11-15 03:27:47 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-11-15 16:24:51 -0500

ozeszty gravatar image

updated 2017-11-17 01:32:39 -0500

No need for more info. With Mesa 17.1 your GPU's OpenGL support was downgraded because "it was slowing down Chrome"... It seems to me that it wasn't the best move, it's Chrome that should have adjusted and blacklisted hardware acceleration on some GPUs, instead of breaking other apps.

Try running blender like that: fragment_shader=true stub_occlusion_query=true blender. You can also append undermentioned code after <driconf> in /etc/drirc and/or ~/.drirc to always run blender with OpenGL 2.1:

    <device driver="i915">
        <application name="Blender" executable="blender">
            <option name="fragment_shader" value="true" />
            <option name="stub_occlusion_query" value="true" />
        </application>
    </device>

You can also use the same approach on other apps, or better yet, buy some cheap, used Radeon GPU which will work out of the box and offer much better performance.

edit flag offensive delete link more

Comments

thanks you, I will test this asap

tamesu gravatar imagetamesu ( 2017-11-15 21:24:42 -0500 )edit

ozeszty, It worked!! Yay \o/. Thanks a lot!

tamesu gravatar imagetamesu ( 2017-11-16 05:55:47 -0500 )edit

You're welcome.

ozeszty gravatar imageozeszty ( 2017-11-17 01:39:46 -0500 )edit
0

answered 2017-11-14 17:59:49 -0500

Probably it is looking for latest version of opengl library. Did you try the command -> dnf update on the system? Hopefully it fetches the latest libraries provided in the repo.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-11-14 13:02:20 -0500

Seen: 293 times

Last updated: Nov 17 '17