How can I always use headphones?

asked 2017-10-26 18:26:14 -0600

Zan Lynx gravatar image

updated 2017-10-27 09:51:49 -0600

Fedora 25, 26, and 27 pop up and ask if I want to use headphones or a headset when I plug in my headphones. I much preferred the older behavior where it was assumed that if headphones were plugged in, you wanted to use headphones.

Another failure of the new behavior is that it sometimes decides to use the laptop speakers without ever asking me if I want headphones, sometimes causing me to embarrassingly blast the office with whatever happens to play.

How can I adjust Pulseaudio on Fedora to always use headphones when plugged in?

This is Intel HDA hardware and a 3.5mm audio jack.

edit retag flag offensive close merge delete

Comments

What kind of headphones are you using? USB connected ones? Bluetooth connected ones? This is rather weird as with standard audio jack it always switches output to the audio port. Also, what kind of soundcard/laptop/motherboard are you using?

masteroman gravatar imagemasteroman ( 2017-10-27 08:06:55 -0600 )edit

@masteroman: I added those details.

Zan Lynx gravatar imageZan Lynx ( 2017-10-27 09:54:02 -0600 )edit

Thank you. Still puzzled a bit. Is there a way to reliably reproduce this behavior? I think the best bet may be to report a bug.

masteroman gravatar imagemasteroman ( 2017-10-27 13:59:01 -0600 )edit