Ask Your Question
1

fedora always ask me for admin password (closed due to fresh install)

asked 2017-10-26 02:20:53 -0600

luca247 gravatar image

updated 2017-10-27 02:48:33 -0600

hi everyone... so, from yersterday morning fedora (26 workstation) started asking me for my admin password every time i try to install/remove a software or i open certain settings...this came out just from yesterday morning because before yesterday it never asked for my password, since my keyring has no pass and the user pass is the same as the root pass...maybe some update changed some policies?(or it's just an error i'm having?how i can remove this and return to a state where fedora does not ask me for a pass? (considering i am the administrator?)

edit retag flag offensive close merge delete

Comments

Did you maybe run dnf or even Gnome as root user? dnf would not ask your password in a root shell.

florian gravatar imageflorian ( 2017-10-26 09:51:44 -0600 )edit

yes, i know...and neither on software center...but it started even if just on software center...the last app i installed before having this was BiglyBT, the new vuze open source clone, so this may be the culprit...but anyway i had installed it other times with no problems at all...

never mind anyway since i've done a clean install and the problem is now gone, and my fedora is more snappier than ever...

luca247 gravatar imageluca247 ( 2017-10-27 02:45:19 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-10-26 04:19:26 -0600

masteroman gravatar image

When removing software it should always ask you for the password. Regarding installation through Software center, it allowed that without providing password. Weird but yeah.

When installing or removing via DNF on the command line, it can do that only when running sudo, and with running sudo before your command, you always need to provide password unless user is configured within sudoers file to use NOPASSWD

edit flag offensive delete link more

Comments

I beg to differ. My regular user is not in wheel, and I have neither access to nor use for sudo as I know the root password. (I'm the one who installed Fedora, so of course I know it.) I update my computer daily with su -c 'dnf upgrade -y' and give the root password.

sideburns gravatar imagesideburns ( 2017-10-26 14:58:23 -0600 )edit

You still provide the password though, root be it, but still.

masteroman gravatar imagemasteroman ( 2017-10-26 17:51:02 -0600 )edit

if i input "su" on a terminal i should give a password too, and i'm fine with it, what i don't like is to have to give the password even in software center and since software center never asked for my pass till the other day i thought there was something wrong...and maybe i was right since a fresh install solved my problem...

luca247 gravatar imageluca247 ( 2017-10-27 02:47:38 -0600 )edit

Asking for password is recommended and default behavior in Fedora. If you want it different, you will have to change sudoer file.

florian gravatar imageflorian ( 2017-10-27 09:16:23 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-10-26 02:20:53 -0600

Seen: 418 times

Last updated: Oct 27 '17