Ask Your Question
1

Looking for people having battery drains with the Kernel 4.13 in F26

asked 2017-10-22 10:08:35 -0600

Hi there,

I encounter a serious bug since the update of the 4.13 series kernel in Fedora 26. While everything worked as expected before the update, after upgrading to 4.13.3 on my laptop, i encounter the following issues :

  • My Realtek rtl8723be driver (rtlwifi) changed, and so i needed to change the parameters given to modprobe
  • I noticed a battery drains while off line since the update (that was solved before because it was a problem with the wake on lan functionality, that was previously always enabled).

If you also encounter this kind of problem, keep me updated, i'll take time to fill a bug.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2017-11-30 12:05:34 -0600

VaporTrail gravatar image

On Fedora 26, by running lscpu I've noticed that my Dell XPS13 runs at max, 2400mhz, clock speed all the time with the 4.13 kernel. By booting into the F26 iso supplied 4.11 kernel, normal cpu throttling between 400mhz and 2400mhz as load increases/decreases. Naturally, my battery drains faster under the full-clocked 4.13 kernel.

With F27, since it comes with 4.13, my XPS runs a max 2400mhz no matter what.

edit flag offensive delete link more
0

answered 2017-11-23 13:43:47 -0600

Len gravatar image

Hi,

I also noticed the same battery problem after upgrading to kernel 4.13. Basically the battery drains even though the laptop has been regularly powered off (by about 30% in one day). I also used to have a similar problem with the wake-on-lan...however, that was solved long ago by permanently disabling the wol functionality.

I haven't been able to solve this new issue. What I know is: (1) If I boot my laptop from kernel 4.12 or from Windows 8.1, then the battery doesn't drain after shutdown; (2) If I force a shutdown by keeping the power button pressed, then the battery doesn't drain.

Any ideas?

edit flag offensive delete link more
0

answered 2017-11-30 16:44:03 -0600

cmurf gravatar image

Kernel 4.13.15 has been stable for 8 days, I recommend upgrading to that. There are rtlwifi bug fixes in 4.13.10. You can also install powertop and run 'sudo powertop' with the laptop unplugged and give it about 5 minutes to stabilize and see what's soaking the battery.

edit flag offensive delete link more

Comments

I'll try to update the next weekend and see what happens ;). Thanks for your help !

guilieb gravatar imageguilieb ( 2017-12-05 11:29:10 -0600 )edit
0

answered 2017-11-29 15:34:55 -0600

Hi !

Good to know that I'm not alone :D.

Well, basicaly, we should identify the source of our problem. This can be done by :

  • identifying the compilation options and looking for differences between the configuration file of the 4.12 and 4.13 branches (those file can be found in /boot/config*)
  • comparing the kernel options on boot, visible in your /boot/grub2 or /boot/efi/grub2 grub.cfg file. By I don't expect to see any difference in here.

Unfortunately, I don't have time to investigate on this :(. Anyway, as the drain is very similar to the one we had without disabling WOL on the Ethernet Card (mine uses r8168 driver), I tend to suspect this driver. If you've got time, try to read the changelog and identify the changes between the two series, about the ethernet driver and the wifi driver (mine is rt8723be).

As you mentioned it, if the drains is absent when forcing the shutdown through the power button, we should incriminate the poweroff procedure. There's maybe a network service that restarts the network service, without reloading our handwritten service that disables WOL.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-10-22 10:08:35 -0600

Seen: 362 times

Last updated: Nov 30 '17