F26 — no login screen

asked 2017-10-21 09:59:05 -0600

schroedinger gravatar image

updated 2017-10-30 17:25:25 -0600

Few weeks ago I upgraded my old notebook from F25 to F26 as described at DNF system upgrade. Since then I don’t have a graphical login screen any longer. Observations:

  1. When using the Wayland display server, the system shows the Fedora logo and a mouse cursor during the boot process, but then switches to text output after some time where it is stuck (not always exactly at the same point). With Wayland the system remains permanently busy and does not permit me to switch to tty2 to log in from there.
  2. When using X display server (via WaylandEnable=false in /etc/gdm/custom.conf), the graphical login screen still does not show up as well, but the system is not permanently busy and I can switch to tty2 and successfully log in there. However, startx (both with and without sudo) does not help to start the GUI, and its stderr gives some interesing output (amoung non-critical logs):
    • xauth: file /home/user/.serverauth.3756 does not exist (with and without sudo, only with different numbers)
    • xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) (without sudo only)
    • xinit: connection to X server lost (without sudo only, startx exits thereafter)
    • Failed to import environment: Process org.freedesktop.systemd1 exited with status 1 (with sudo only, startx hangs thereafter)
  3. I can also successfully chroot into the system from a live system, and it is up to date (sudo dnf upgrade).
  4. (Added 2017-10-30) When using the nomodeset option in GRUB2, I get a login screen and a working system—with limited graphics.

The system is an older (2006) notebook computer with an ATI Radeon Xpress 200M graphics card, where I am not sure whether it is still supported by any drivers. Unfortunately I am not proficient enough to solve this by myself, so I request advice and I am willing to provide whatever information is necessary here. Thanks in advance!

edit retag flag offensive close merge delete

Comments

Open /etc/selinux/config and change SELINUX=enforcing to SELINUX=permissive, and then boot your Fedora and see if you can get to the graphical login screen.

hedayat gravatar imagehedayat ( 2017-10-28 13:25:30 -0600 )edit

Thanks, but no change unfortunately when using SELINUX=permissive (or even SELINUX=disabled). Please also mind my amendment to the original post after I made new observations.

schroedinger gravatar imageschroedinger ( 2017-10-30 17:29:32 -0600 )edit

Get into /etc/X11/xorg.conf and put in

Section "Device"
    Identifier  "Videocard0"
    Driver      "radeon"
    Option "AccelMethod" "XAA"
    Option "AccelDFS" "off"
    Option "DRI" "off"
EndSection

Let me know how that does

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-10-30 21:09:15 -0600 )edit

Thanks. /etc/X11/xorg.conf did not exist, so I touched it. There is no improvement if I put in the exact content you gave, but it then doesn’t even work with the nomodeset option any longer. I thus removed the new file again for now.

schroedinger gravatar imageschroedinger ( 2017-10-31 03:43:24 -0600 )edit

what is shown in the one that is created by the system?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-11-01 12:21:23 -0600 )edit