Ask Your Question
0

I need journalctl help

asked 2017-10-21 04:15:31 -0600

toddandmargo gravatar image

Hi All,

What am I doing wrong with this command?

# journalctl -efx -t=start.stop.pro5ds.sh

Nothing shows up.

I write to the journal with

# echo 'stop: No instances of pro5.server were found' | /usr/bin/systemd-cat -p info -t start.stop.pro5ds.sh

and it shows up in /var/log/messages:

Oct 21 02:12:05 FedoraServer start.stop.pro5ds.sh: stop: No instances of pro5.server were found

Many thanks, -T

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-10-21 04:39:59 -0600

villykruse gravatar image

updated 2017-10-21 04:42:25 -0600

Don't put the equals sign after -t

journalctl -t start.stop.pro5ds.sh

works for me

journalctl -t=start.stop.pro5ds.sh

does not.

journalctl --identifier=start.stop.pro5ds.sh

also works, and with the long options you do use the equals sign, but not with the short option.

edit flag offensive delete link more

Comments

that was easy. Thank you!

toddandmargo gravatar imagetoddandmargo ( 2017-10-21 04:59:25 -0600 )edit

the man page says:

 -t, --identifier=SYSLOG_IDENTIFIER
       Show messages for the specified syslog identifier SYSLOG_IDENTIFIER.

Should the "=" be removed?

toddandmargo gravatar imagetoddandmargo ( 2017-10-21 05:03:29 -0600 )edit

If it was written like this:

-t SYSLOG_IDENTIFIER
--identifier=SYSLOG_IDENTIFIER
       Show messages for the specified syslog identifier SYSLOG_IDENTIFIER.

It might be clearer.

It is using the standard GNU convention of specifying options and arguments. Also, you can bundle the short options like -efx sames as -e -f -x or even -efxtSYSLOG_IDENTIFIER with or without space between the t option and its argument.

villykruse gravatar imagevillykruse ( 2017-10-21 07:09:50 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-10-21 04:15:31 -0600

Seen: 53 times

Last updated: Oct 21 '17