Ask Your Question
2

[Solved]Fail to send encrypted emails using evolution

asked 2017-10-20 01:55:24 -0600

AKoine gravatar image

updated 2017-11-01 09:30:00 -0600

Hi there,

I can't send encrypted emails using evolution. I managed to import my private pgp key, as well as the public key of my intended recipient, using command line. These keys are visible in seahorse. In my email account properties -> security tab, field "ID of the OpenPGP key" I typed the 8 last digits of my private key (found using the command "gpg --fingerprint"). (sorry if the translation of the tabs and error messages are not perfect, I run a french localised fedora) Good news is I can decrypt emails sent to me by the recipient mentioned above.

However, when I want to reply, I get the following error message (XXing the keys ID):

Il se peut que vous ayez besoin de choisir d'autres options de messagerie.
Détails de l'erreur : Échec de chiffrement : destinataire 0 XXXXXXXX non valide. Une raison fréquente est que gpg2 n'a pas importé de clé publique pour ce destinataire.

approximate translation :

You may need to select different mail options. Error details : encryption failed : recipient 0 XXXXXXXX is not valid. A common issue is that gpg2 has not imported the public key for this recipient.

From there :

  1. If I tick the box "Always encrypt for myself when sending encrypted emails" in the security tab of my email account properties, the XXXXXXXXX of the previous error message are replaced by my pgp key ID (see above)
  2. If I do not tick the box "Always encrypt for myself when sending encrypted emails" in the security tab of my email account properties, the XXXXXXXXX are replaced by my recipient email address (for which the public key seems correctly imported since visible in seahorse, see above)

Does any of this sounds familiar to anyone out there ?

Merci beaucoup !!

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2017-11-01 09:28:54 -0600

AKoine gravatar image

updated 2017-11-02 04:59:15 -0600

Solution found thanks to villykruse : Just tick the box "Always trust keys in my keyring when encrypting" in the security panel of your email account. To do so, from the Evolution Main Menu, select Edit -> Preferences. In the left pane, select Mail Accounts. In the right pane, select the email account you use for Fedora Project correspondence. Then select the Edit button. The Account Editor dialog appears. Select the Security tab. This this guide for a screenshot.

Hope this will help somebody else.

edit flag offensive delete link more
0

answered 2017-10-22 11:00:25 -0600

AKoine gravatar image

Hi,

Thanks for the reply.

When I tick those boxes, and I try to send an encrypted message to myself, I got the following error : "Il se peut que vous ayez besoin de choisir d'autres options de messagerie. Détails de l'erreur : Échec de chiffrement : destinataire 0 XXXXXXXX non valide. Une raison fréquente est que gpg2 n'a pas importé de clé publique pour ce destinataire." Which I roughly translate as follows :

You may need to select different mail options. Error details : encryption failed : recipient 0 XXXXXXXX is not valid. A common issue is that gpg2 has not imported the public key for this recipient.

Maybe the problem comes from the way I selected my GPG key you mentioned in step 1 : I typed the last 8 digits returned by the command "gpg --fingerprint". Should I have been able to select it from a drop-down list or use a different command to determine it ?

Thanks again for your help,

edit flag offensive delete link more

Comments

Did you mark the gpg public keys as trusted?

villykruse gravatar imagevillykruse ( 2017-10-22 11:10:59 -0600 )edit

If you imported key with gpg utility it may simply be that you've imported it under GPG 1 while program uses GPG 2. Ensure you have key both under gpg and gpg2

masteroman gravatar imagemasteroman ( 2017-10-22 16:10:56 -0600 )edit

No, I did not mark the gpg key as trusted. How do I do that ? In seahorse, when I try to sign the key (as I guess that would be what you're suggesting), I get a "failed to sign the key. General error" window poping up.

How can I know in which gpg a key has been imported ?

AKoine gravatar imageAKoine ( 2017-10-30 17:23:42 -0600 )edit
1

According to this guide you can set a check mark for trusting everything in you gpg key ring.

To trust an individual entry:

gpg2 --edit-key receover@somwhere

replacing receover@somwhere with the real email address of the receiver.

At the gpg> prompt, type trust, and the dialog will guide you further.

seahorse should be able to do this, but for me id did not work. (bug?)

villykruse gravatar imagevillykruse ( 2017-10-31 03:23:25 -0600 )edit

Thanks for the reply, ticking the box "Always trust keys in my keyring when encrypting" did the trick for me !

AKoine gravatar imageAKoine ( 2017-11-01 09:26:02 -0600 )edit
0

answered 2017-10-20 12:03:36 -0600

masteroman gravatar image

When going on Edit > Preferences > Mail accounts > YourEMAILAccountOnTheRightHandside > Edit under "Security" tab I have following options turned on:

  • OpenPGP Key ID : selected my my GPG key.
  • Always sigh outgoing messages when using this account
  • Always encrypt outgoing messages when using this account
  • Always encrypt to myself when sending encrypted messages

Note that those options are all under OpenPGP section. Last option also exists under S/MIME section so be sure to not confuse those two. With that set up I can successfully send encrypted messages to myself.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-10-20 01:55:24 -0600

Seen: 608 times

Last updated: Nov 02 '17