Ask Your Question
1

Wifi-WPA2 vulnerability & KRACK - security update fedora-25?

asked 2017-10-17 06:05:15 -0500

selma gravatar image

Does wpa_supplicant v 2.6 provide solution for the wpa2 krack vulnerability that was reported in October 2017?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2017-10-17 06:43:49 -0500

masteroman gravatar image

Package fixing this vulnerability is wpa_supplicant-2.6-3.fc25.1

You can find exact steps on how to patch on Fedora Magazine page

edit flag offensive delete link more
-1

answered 2017-10-17 07:31:32 -0500

selma gravatar image

OK. Thank you. This seems to be the same package that comes with fedora 25.

edit flag offensive delete link more

Comments

This is a different package from what is shipped with Fedora 25!

The fixed package was pushed to the Fedora repositories only yesterday. The previous package (wpa_supplicant-2.6-3.fc25 from July 2017) is affected by the vulnerability!

See here for a list of all wpa_supplicant builds.

The fixed package is named: wpa_supplicant-2.6-3.fc25.1. Note the .1.

florian gravatar imageflorian ( 2017-10-17 12:22:07 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-10-17 06:05:15 -0500

Seen: 334 times

Last updated: Oct 17 '17