Ask Your Question

Codec H264

asked 2017-10-16 03:03:08 -0500

vizirex gravatar image


I tried many times to install the H264 Codec for playing HTML5/Flash video etc on ALL BROWSERS , using the software button on Fedora bar desktop, and the OS is stll unable to fix that issue...

I had the same headache with OpenSuse and wonder If that isnt due to my Harware config:

-OS: Fedora 26, Gnome 3.24.2, 64 bits -CPU: Intel® Core™ i3-2100 CPU @ 3.10GHz × 4 -Graphic:NVA8 -Memory: 8GB

PS: I'm not fond of programming, jus an ordinary user

Thanks a lot


edit retag flag offensive close merge delete


Welcome to ask.fedora! I don't think that your hardware is at fault, because that shouldn't prevent you from installing the codec, although it might prevent you from using it. How are you trying to install it, and what happens when you do? Please put the details in your question, so that people can see them more easily.

sideburns gravatar imagesideburns ( 2017-10-16 04:13:02 -0500 )edit

Maybe it's some hardware video acceleration issue. What GPU driver are you using?

ozeszty gravatar imageozeszty ( 2017-10-19 12:34:48 -0500 )edit

5 Answers

Sort by » oldest newest most voted

answered 2017-10-16 14:23:04 -0500

davidva gravatar image

You need rpmfusion or unitedrpms and install "x264-libs" . It is all!

edit flag offensive delete link more

answered 2017-10-19 10:02:00 -0500

vizirex gravatar image

Sideburns, I try from the software desk icon, then >extensions >Gstreamer Multimediaplayback for H264, and although I click many times on install, nothing happens...

Davidva, I Installed the rpmfustion but do not seem to work, need to be reinstalled each times...

Thanks anyway, may works sooner or later...

edit flag offensive delete link more


Please provides:

dnf repolist

rpm -q ffmpeg

rpm -q x264-libs

Are you tested with unitedrpms?

davidva gravatar imagedavidva ( 2017-10-19 11:23:48 -0500 )edit

answered 2017-10-16 15:21:51 -0500

fcomida gravatar image

This is for Firefox OpenH264

edit flag offensive delete link more


Willtech gravatar imageWilltech ( 2019-03-02 20:59:34 -0500 )edit

answered 2017-10-16 11:33:28 -0500

go to Preferences > Content > Tick on "Play DRM Content"

try this in firefox It may help

edit flag offensive delete link more

answered 2017-10-19 10:30:02 -0500

Worked for me! thanks

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-10-16 03:03:08 -0500

Seen: 3,366 times

Last updated: Oct 19 '17