Gdm and/or GNOME show black screen on Xorg for Fedora 26

asked 2017-10-15 14:39:14 -0600

elcoyote gravatar image

Hi everyone, I have a Lenovo W541 laptop that has been running FC22/23/24/25 with Xorg just fine for years (literally). To achieve this, I had:

1)  WaylandEnable=false uncommented in /etc/gdm/custom.conf
2) I was choosing 'GNOME on Xorg' at the GDM login screen.

I updated to FC26 just moments ago and I noticed that if I keep the above settings, then all I get is a black screen:

1) in order to actually 'see' gdm-login, I had to re-enable Wayland (I set "# WaylandEnable=false" in /etc/gdm/custom.conf )
2) from the wayland enabled GDM login screen, 'GNOME' (on wayland) works fine but 'Gnome on Xorg' shows a black screen (just like GDM when using Xorg).

I was unable to find anything relevant in the logs.. is this Xorg thing a known problem? Thanks for reading, ideas very welcomed.
Vincent

edit retag flag offensive close merge delete

Comments

Which logs did you check? Did you check /var/log/Xorg.0.log? If you've rebooted multiple times since the problem it may be in Xorg.1.log or an older log.

ifohancroft gravatar imageifohancroft ( 2017-10-15 15:55:57 -0600 )edit

I had not checked this first but I got this in my user's Xorg.0.log:

# grep EE /export/home/vcojot/.local/share/xorg/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   228.798] (EE) open /dev/fb0: Permission denied
[   229.384] (EE) modeset(0): failed to set mode: Invalid argument
elcoyote gravatar imageelcoyote ( 2017-10-16 08:31:13 -0600 )edit