Ask Your Question
0

Hello Any installation or update that I do show this problem to me what is the solution to fix this bug (working with fedora 26)

asked 2017-10-15 01:42:21 -0600

Total 148 kB/s | 4.4 MB 00:30
Delta RPMs reduced 14.1 MB of updates to 4.4 MB (68.1% saved) warning: /var/cache/dnf/mysql56-community-e7223972839acae4/packages/mysql-community-libs-5.6.37-2.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY Cannot download file:/etc/pki/rpm-gpg/RPM-GPG-KEY-mysql: All mirrors were tried The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing 'dnf clean packages'.

edit retag flag offensive close merge delete

Comments

sudo rpm --import http://dev.mysql.com/doc/refman/5.6/en/checking-gpg-signature.html

fcomida gravatar imagefcomida ( 2017-10-15 08:07:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-10-15 13:54:00 -0600

villykruse gravatar image

It looks like someone has been messing with the file in /etc/yum.repos. The url for the gpg key looks wrong; I would expect file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql. The downloaded package is not a package built for fedora but a package built of Redhat Entreprice Linux 7. I would suggest to remove the repositories referring to the mysql site.

https://dev.mysql.com/downloads/mysql has the download for rpms which will install the proper repository files in /etc/yum.repos; a different rpm for each system type, so select the correct one for your fedora version.

Another thing: The community mysql is also available from the fedora repository:

dnf install community-mysql

will install that version.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-10-15 01:39:56 -0600

Seen: 77 times

Last updated: Oct 15 '17