High pitched audio-recording when using onboard soundcard.

asked 2017-10-01 11:44:52 -0600

anotherriddle gravatar image

updated 2017-10-02 14:31:37 -0600

Hi everyone :) I am new, so please bear with me.

My observations

I am trying to record sound with a new microphone via my onboard soundcard and everything becomes very high pitched, like when you play back an audio recording too fast. (I am not exactly sure, but I believe the behaviour started after I changed the recording amplification in the audio settings GUI. ->apparently this is not the case, as using a live-USB without modification yields the same results) When I watch the audio position timer in the bottom right of Audacity I can see that it progresses too slowly while recording. This would explain the high pitched sound when playing back at normal speeds. The problem is, I do not know what to do about this.

Things I tried:

  • Turning it off and on again ;-)
  • using different recording software -Audacity and the GNOME audio recorder- (the same behaviour in both)
  • changing the "default-sample-rate" in /etc/pulse/daemon.conf (no change in behaviour)
  • reinstalling Pulseaudio (no change)
  • using a cheap USB soundcard ( here the recording speed is correct )

My system:

  • Fedora 26
  • GNOME version 3.24.2
  • using SELinux in enforced mode
  • btrfs file system
  • Motherboard: Asus PRIME-X370-PRO

Any instructions for further troubleshooting would be very welcomed. I don't have any ideas left :/


Update:

Ok, now I'm getting down on something:

I tried recording from the terminal with arecord and it works! However, as soon as I open Audacity the symptom of the high pitched recording starts. Even if I record again with arecord or the GNOME audio recorder afterwards those programs also record with a high pitch. I have to reboot to get back to normal. This happens even after reinstalling Audacity.

This behaviour is 100% repeatable.

What does Audacity change for this to happen?

edit retag flag offensive close merge delete

Comments

1

Try deleting PulseAudio settings (backup content of ~/.config/pulse, delete it, reboot and test) or create new user, just for testing.

Or maybe it's this issue with overdub recording (here you'll also find instruction how to fix sound in what you already recorded)?

Make sure BIOS and Fedora are updated.

ozeszty gravatar imageozeszty ( 2017-10-01 16:49:29 -0600 )edit
  • I deleted the content of ~/.config/pulse and rebooted, no change, the recording is still high pitched
  • Thanks for the link regarding overdub recording, I tried everything in the list that is relevant for Linux exept the drivers. I don't know how to go about drivers, however this is a relatively new installation (barely 3 weeks) and I believe the drivers come with the kernel. Also there are no known problems with the board regarding audio.
  • Fortunately I was in the process of setting up and testing, no importand recordings yet.
  • Fedora is up to date and the latest BIOS is installed
anotherriddle gravatar imageanotherriddle ( 2017-10-02 02:44:58 -0600 )edit
1

The driver is built into kernel so you may try out version 4.13 dnf update kernel* --enablerepo=updates-testing, but since it started after playing with settings, I'd test recording on a fresh user profile.

ozeszty gravatar imageozeszty ( 2017-10-02 04:11:58 -0600 )edit

Ok, apparently creating a new user and recording as said user does not change anything. Maybe I remembered it wrong and it always recorded that way. I just have no way to check. Thanks for your help by the way, it's very much appreciated.

anotherriddle gravatar imageanotherriddle ( 2017-10-02 07:03:45 -0600 )edit
1

If you're unsure, crate Live USB, boot it, and you'll see if it used to work. It might as well be a regression.

You're welcome. I prefer to actually solve the puzzle, though ;)

ozeszty gravatar imageozeszty ( 2017-10-02 07:47:38 -0600 )edit