Ask Your Question
1

dual screen

asked 2017-09-27 04:39:52 -0600

jwiberg gravatar image

updated 2017-09-27 06:49:38 -0600

hhlp gravatar image

Hi, I just installed Fedora 26 on my computer:

Motherboard:  ASUS PRIME X370-PRO
CPU:  AMD Ryzen 7 1700 3.7 GHz 20MB
GraphicsCard: ASUS GeForce GTX 1050 Ti 4GB

It works fine using one screen, but as soon as I plug in a second fedora hangs and I have to reboot.

I get the following messages at startup (using one screen):

ACPI Error: Needed [Integer/String/Buffer], found [Region] ffff9cce5e96ed80 (20170303/expresop-424)
ACPI Exception: AE_AML_OPERAND_TYPE, Could not execute arguments for [IOB2] (Region) (20170303/nsinit-412)
nouveau 0000:28:00.0: DRM: Pointer to flat panel table invalid
sp5100_tco: I/O address 0x0cd6 already in use

I guess the two first rows are not related to the graphics issue?

I'm logging in using default GNOME.

Anyone knows why I get the errors at startup and why I cannot connect the second screen? Anymore information needed? :)

thanks in advance

edit retag flag offensive close merge delete

Comments

I do not think nouveau works with dual screen. I would use the nvidia driver, direct from nvidia.com and you can search forums for the install steps I use to properly set it up for fully automatic updates when new kernels come out.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-09-27 13:27:56 -0600 )edit

Thanks! Installed the driver from nvidia.com and it works like a charm!

jwiberg gravatar imagejwiberg ( 2017-10-01 14:27:12 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-09-27 13:58:02 -0600

ozeszty gravatar image

Hi, it's probably some bug in open source Nvidia driver (nouveau), report it here. Unfortunately Nvidia precludes nouveau development for newer GPUs and for now you're better off using proprietary driver.

Install Nvidia proprietary driver from rpmfusion, it should automatically disable nouveau. You'll be getting newer driver versions with the rest of system updates, so it's very convenient.

Make sure you're using latest BIOS and keep Fedora updated, sooner or later those ACPI errors should be ironed out.

edit flag offensive delete link more

Comments

Thanks for your suggestion. I tried the option steveebey73742 proposed and it worked.

jwiberg gravatar imagejwiberg ( 2017-10-01 14:28:32 -0600 )edit

Remember that this way (nvidiacom+dkms) you'll only get automatic recompilation after kernel update, but:

  • when there's a newer version of nvidia driver, you'll have to download and install it manually;
  • when there's a newer major version of kernel or XOrg, with which this driver won't be compatible, again you'll have to download newer driver and install it manually.

Both those issues are non-existent with RPMFusion, since maintainers are keeping driver updated and you're getting those updates along with system updates. Of course with minor kernel updates this driver is also recompiled.

ozeszty gravatar imageozeszty ( 2017-10-01 16:17:04 -0600 )edit

@ozeszty, rpm require you to take what the maintainer chooses to package, which might include 32 bit, but I do not need 32bit, and see no way to specify that, when I used rpm. I can tell proprietary not to intall 32 bit, and all is good.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-10-02 07:49:48 -0600 )edit

@steveebey73742, does installing RPMFusion packages with .x86_64 suffix help?

Anyway, I found 'fully automatic updates' phrase misleading and wanted to warn and explain it. Now @jwiberg knows what to expect and can decide what to do.

ozeszty gravatar imageozeszty ( 2017-10-02 08:23:36 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2017-09-27 04:39:52 -0600

Seen: 766 times

Last updated: Sep 27 '17