Ask Your Question
0

Why isn't my display fading to black on blank/lock?

asked 2017-09-06 01:42:26 -0600

FeRDNYC gravatar image

I'm running Fedora 25 (still) on a desktop PC, using Xorg instead of Wayland because my display is driven by an Nvidia card using the proprietary drivers. I can say with a fair amount of certainty that none of those details are the source of my problem, because they're identical to the setup of my previous system. On that system (now sadly deceased), whenever the idle timer expired (or I manually locked the system), the screen would very gently fade to black. Among other things, this gave me sufficient warning to wake the display, if I didn't actually want the screen to turn off at that moment.

On the machine I'm now using, though, the slow fade-out effect is completely absent, and when the system becomes idle the screen will just suddenly turn off with no warning whatsoever. Same thing if I hit Super-L (which I have bound to "Lock screen", I can't recall if that's a default binding), I actually get a momentary glimpse of "shield" screen's time display, and then the display goes instantly black. There's no gentle transition at all. The more rapid fade-in effects going the other direction, which would normally be seen when I log in or wake the display, are also missing.

I tried to locate a variable in dconf-editor that might control the fading or adust the fade speed, but there didn't seem to be anything there. At least in the original patches to screenshield.js that implemented the fade effect, everything appears to be hardcoded and not configurable at all (though it's possible that subsequently changed). But some searching online didn't turn up any information about adjusting or disabling the fade effect, so I'm not sure what would interfere with it just automatically being used, or what I could do to restore it.

edit retag flag offensive close merge delete

Comments

I've not noticed earlier, but the fade effect seems to be removed from Gnome. I don't see it either in F26.

hedayat gravatar imagehedayat ( 2017-09-15 08:15:55 -0600 )edit

@hedayat: I don't think that's it, because not only is the machine in question running Fedora 25, but my laptop (which is running Fedora 26) still does use the fade-to-black effect when blanking the screen. It sounds like you may be having the same problem that I am.

FeRDNYC gravatar imageFeRDNYC ( 2017-09-16 18:49:20 -0600 )edit

Oh...thanks. I don't know. maybe my system is too slow (and the fade effect has become faster!) for it. BTW, I've only tested the locking. I'm not sure if it also doesn't work for me when the system is idle and it blanks the screen.

hedayat gravatar imagehedayat ( 2017-09-17 03:31:32 -0600 )edit

@hedayat Yeah, I ended up testing on mine by lowering the blanking timeout to 2 minutes and just waiting. Seemed simplest.

FeRDNYC gravatar imageFeRDNYC ( 2017-09-28 14:03:54 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-09-28 14:06:20 -0600

FeRDNYC gravatar image

Well, it isn't much of an answer, but I ended up just upgrading the machine to F26 for other reasons, and blanking is all back to normal now — fade-ins/outs and everything. (Using both the nvidia and nouveau drivers, which I'm still bouncing between while chasing a different problem.)

edit flag offensive delete link more

Comments

Good to hear that it is working anyways :)

hedayat gravatar imagehedayat ( 2017-09-28 17:25:29 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-09-06 01:42:26 -0600

Seen: 160 times

Last updated: Sep 06 '17