Ask Your Question
1

Emacs key binding Ctrl+Space not working on Fedora 16 GNOME or XFCE

asked 2011-11-14 23:42:20 -0600

tuxdna gravatar image

Emacs key binding Ctrl+Space not working on Fedora 16 GNOME or XFCE

Is Ctrl+Space being intercepted by GDB or by IBus ?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-15 00:00:28 -0600

tuxdna gravatar image

I figured it out myself.

In Gnome Shell top panel, right click the "IBus input method framework" and select Preferences. This will open "IBus Preferences" window.

Then in "Keyboard Shortcuts", if "Toggle" has "Control-space" keyboard shortcut, delete it ( add add another shortcut if you need to ).

Now restart Emacs.

edit flag offensive delete link more
0

answered 2011-11-15 16:37:18 -0600

alexlan gravatar image

I have the same issue as above. I don't actually have iBus Preferences running at all. I also removed "Ctrl-space" from Keyboard Shortcuts, and restarted Emacs, but still can't get Ctrl-space to work inside Emacs.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-11-14 23:42:20 -0600

Seen: 2,899 times

Last updated: Nov 15 '11