Fail to Connect on 5ghz Band

asked 2017-08-16 08:51:11 -0600

tauceti gravatar image

Recently replaced my WiFi board in this HP ProBook 6570b notebook. It was a Broadcomm chipset card that failed after years of use, would no no longer activate at all.

After some work with the configuration files, I have the new card, INTEL Centrino Advanced-N 6205, Dual Band connecting to the router, but it only connects on the 2.4ghz band (on any of the channels that uses.)

When I try to connect to the 5ghz band, Fedora's NetworkManager spins for a while then returns, "The network connection has been disconnected" then it connects to the 2.4ghz band again.

I'm not sure what next step to take. Currently iPads, Android phones and other laptops are able to connect to the 5ghz network. It has a unique name, different from the 2.4ghz SSID. I've tried setting the router to low channels (per one suggestion), putting a unique MACADDR in the configuration file,

/etc/sysconfig/network-scripts/ifcfg-Nname2

This laptop used to connect on the higher band until the Broadcom card died. Does anyone have a suggestion to make this work? Thanks.

edit retag flag offensive close merge delete

Comments

1

Run journalctl -lf and then try connecting to the 5GHz network. When it failed, post the generated logs (e.g. using fpaste command) to us to see if it helps.

hedayat gravatar imagehedayat ( 2017-08-21 16:37:48 -0600 )edit

Last session I tried a number of things - using cli to set up the connection; GUI's - Wicd Network Manager & Wireshark; and editing the ifcfg-Nname2 file. Looks like the connection was made, I didn't even know until working with journalctl today,

iw wlo1 link
    Connected to 2x:xx:xx:yy:yy:yy (on wlo1)
        SSID: Nname2
        freq: 5200
        RX: 1303886 bytes (6959 packets)
        TX: 56983 bytes (381 packets)
        signal: -69 dBm
        tx bitrate: 90.0 MBit/s MCS 3 40MHz short GI
        bss flags:  short-slot-time
        dtim period:    3
        beacon int: 100
tauceti gravatar imagetauceti ( 2017-08-24 15:24:41 -0600 )edit