Ask Your Question
1

Fedora 26 | gnome-rdp not working

asked 2017-08-04 09:46:18 -0500

wil gravatar image

Hi everybody!

I have recently install Fedora 26 and I'm having trouble opening gnome-rdp sessions. On fedora 23 i was not problem.

I get this message from log:

Information: Creating process for rdesktop  -d mydomain -u myuser -p "mypassword" -k es -g 1368x700 -a 16 -z -x l -5 -r sound:local 192.168.1.4   
Error: No process is associated with this object.
Verbose: System.InvalidOperationException: No process is associated with this object.
  at System.Diagnostics.Process.EnsureState (System.Diagnostics.Process+State state) [0x0001e] in <f8255d9ef0594d18ae2c0d97286b9a80>:0 
  at System.Diagnostics.Process.EnsureState (System.Diagnostics.Process+State state) [0x00037] in <f8255d9ef0594d18ae2c0d97286b9a80>:0 
  at System.Diagnostics.Process.GetProcessHandle (System.Int32 access, System.Boolean throwIfExited) [0x00089] in <f8255d9ef0594d18ae2c0d97286b9a80>:0 
  at System.Diagnostics.Process.GetProcessHandle (System.Int32 access) [0x00000] in <f8255d9ef0594d18ae2c0d97286b9a80>:0 
  at System.Diagnostics.Process.WaitForInputIdle (System.Int32 milliseconds) [0x00002] in <f8255d9ef0594d18ae2c0d97286b9a80>:0 
  at System.Diagnostics.Process.WaitForInputIdle () [0x00000] in <f8255d9ef0594d18ae2c0d97286b9a80>:0 
  at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:WaitForInputIdle ()
  at GnomeRDP.SessionHost.WorkerThread () [0x0005c] in <794978738ed449a4b4f09b95276c2dc4>:0

It work without problem when starting from command line:

$ rdesktop  -d mydomain -u myuser -p "mypassword" -k es -g 1368x700 -a 16 -z -x l -5 -r sound:local 192.168.1.4

Apreciate your help.

Bests regards.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-02 07:53:17 -0500

I have the same issue. I upgraded Korora 25 (a Fedora25 spin) to Korora 26 and got the same result from gnome-rdp it asks for the password when openeing an RDP session, but after that nothing. From the CLI manually it works like a charm.

edit flag offensive delete link more
0

answered 2017-10-09 07:31:28 -0500

Hi an addition from me. I did a clean install of Fedora and also Korora 26 on a laptop of mine, and both installations did not have a working gnome-rdp gui. Both did work from the CLi. Is there anyone that found what was wrong and want to share the fix for it?

edit flag offensive delete link more
0

answered 2018-05-02 08:46:57 -0500

And yet another 2 upgrades... 1 to a new Machine in general, and with a fresh install of Fedora 27 didn't work and today upgraded to Fedora 28 and still the same error... Still no-one?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-08-04 09:46:18 -0500

Seen: 511 times

Last updated: Aug 04 '17