Ask Your Question
1

fedora26: Can't change default-browser

asked 2017-08-03 08:38:55 -0600

MarcoDePollo gravatar image

Minor Issue, I know, but I can't change the default browser from Firefox to Google Chrome.

[ronni@hephasto ~]$ xdg-settings get default-web-browser
firefox.desktop
[ronni@hephasto ~]$ xdg-settings set default-web-browser google-chrome.desktop
[ronni@hephasto ~]$ xdg-settings get default-web-browser
firefox.desktop
[ronni@hephasto ~]$
edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2017-08-06 04:48:32 -0600

MarcoDePollo gravatar image

The problem seems to relate to KDE Plasma. I installed Mate Desktop and now XDG-settings behave correctly:

[ronni@hephasto ~]$ xdg-settings get default-web-browser
google-chrome.desktop
[ronni@hephasto ~]$ xdg-settings set default-web-browser firefox.desktop
[ronni@hephasto ~]$ xdg-settings get default-web-browser
firefox.desktop
[ronni@hephasto ~]$ xdg-settings set default-web-browser google-chrome.desktop
[ronni@hephasto ~]$ xdg-settings get default-web-browser
google-chrome.desktop
[ronni@hephasto ~]$
edit flag offensive delete link more
0

answered 2017-08-03 18:06:58 -0600

Aeyoun gravatar image

That is the behavior when the system doesn’t know the desktop file you’re talking about. Have you installed it? xdg-desktop-menu full-path/google-chrome.desktop and then xdg-settings set default-web-browser google-chrome.desktop. You could also try setting it to the full path.

Can you change your default browser from the UI? Go to System Settings: Details: Default applications: Web browser.

edit flag offensive delete link more
0

answered 2018-02-14 05:31:50 -0600

I am using Fedora KDE and I solved the default browser problem as follows.

System Settings Under Personalization select Applications Then under Default Applications select web browser.

Now this did not work at first. Here's how I made it work. I selected Chrome as my browser and clicked Apply. Still Chrome reported it wasn't the default browser. Then inside Default Applications I clicked "with the following command:" and accepted the default then clicked Apply. Still Chrome reported it wasn't the default browser. Then inside Default Applications I again changed back to selecting Chrome as my browser and clicked Apply.

Mysteriously it works now.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-08-03 06:08:21 -0600

Seen: 3,246 times

Last updated: Aug 06 '17