Ask Your Question
1

julius dependency problem

asked 2012-10-30 00:33:43 -0600

oddasee gravatar image

updated 2012-10-30 10:59:22 -0600

mattdm gravatar image

Hello:

I have a dependency problem with the julius speech recognition (development) software. The output from yum I get is:

Loaded plugins: langpacks, presto, refresh-packagekit
Dropbox                                                                                                                                            |  951 B     00:00     
adobe-linux-i386                                                                                                                                   |  951 B     00:00     
google                                                                                                                                             |  951 B     00:00     
google-chrome                                                                                                                                      |  951 B     00:00     
google-earth                                                                                                                                       |  951 B     00:00     
google-talkplugin                                                                                                                                  |  951 B     00:00     
infinality                                                                                                                                         | 2.9 kB     00:00     
infinality-noarch                                                                                                                                  | 2.9 kB     00:00     
rpm-sphere                                                                                                                                         | 1.7 kB     00:00     
rpmfusion-free-updates                                                                                                                             | 3.3 kB     00:00     
rpmfusion-nonfree-updates                                                                                                                          | 3.3 kB     00:00     
updates/metalink                                                                                                                                   |  15 kB     00:00     
rpm-sphere/primary                                                                                                                                 | 1.2 MB     00:59     
1393b9482c4e516d5ce2791c4715f5 FAILED curl#6 - "Couldn't resolve host"         
http://ftp.sjtu.edu.cn/sites/download1.rpmfusion.org/free/fedora/updates/17/i386/repodata/1393b9482c4e516d5ce2791c4715f563b2e5bbad46d51b6850e1c98acead13c2-primary.sqlite.bz2: [Errno 14] curl#6 - "Couldn't resolve host"
Trying other mirror.
9801bb94225c771a72b81f50223c91 FAILED curl#6 - "Couldn't resolve host"         
http://ftp.sjtu.edu.cn/sites/download1.rpmfusion.org/nonfree/fedora/updates/17/i386/repodata/9801bb94225c771a72b81f50223c91faa6174f73faf83af0b7c502427dc02be0-primary.sqlite.bz2: [Errno 14] curl#6 - "Couldn't resolve host"
Trying other mirror.
(1/2): rpmfusion-nonfree-updates/primary_db                                                                                                        | 142 kB     00:01     
(2/2): rpmfusion-free-updates/primary_db                                                                                                           | 263 kB     00:02     
rpm-sphere                                                                                                                                                      4580/4580
Resolving Dependencies
--> Running transaction check
---> Package julius.i686 0:4.2.1-16.1 will be updated
---> Package julius.i686 0:4.2.1-20.1 will be an update
--> Processing Dependency: /bin/perl for package: julius-4.2.1-20.1.i686
---> Package perl.i686 4:5.14.2-212.fc17 will be updated
---> Package perl.i686 4:5.14.2-215.fc17 will be an update
---> Package perl-CGI.noarch 0:3.52-212.fc17 will be updated
---> Package perl-CGI.noarch 0:3.52-215.fc17 will be an update
---> Package perl-CPAN.noarch 0:1.9600.01-212.fc17 will be updated
---> Package perl-CPAN.noarch 0:1.9600.01-215.fc17 will be an update
---> Package perl-Digest-MD5.i686 0:2.51-212.fc17 will be updated
---> Package perl-Digest-MD5.i686 0:2.51-215.fc17 will be an update
---> Package perl-Digest-SHA.i686 1:5.61-212.fc17 will be updated
---> Package perl-Digest-SHA.i686 1:5.61-215.fc17 will be an update
---> Package perl-ExtUtils-Install.noarch 0:1.56-212.fc17 will be updated
---> Package perl-ExtUtils-Install.noarch 0:1.56-215.fc17 will be an update
---> Package perl-ExtUtils-ParseXS.noarch 1:2.2210-212.fc17 will be updated
---> Package perl-ExtUtils-ParseXS.noarch 1:2.2210-215.fc17 will be an update
---> Package perl-Module-Pluggable.noarch 1:3.90-212.fc17 will be updated
---> Package perl-Module-Pluggable.noarch 1:3.90-215.fc17 will be an update
---> Package perl-PathTools.i686 0:3.33-212.fc17 will be updated
---> Package perl-PathTools.i686 0:3.33-215.fc17 will be an update
---> Package perl-Pod-Escapes.noarch 1:1.04-212.fc17 will be updated
---> Package perl-Pod-Escapes.noarch 1:1.04-215.fc17 will be an update
---> Package perl-Pod-Simple.noarch 1:3.16-212.fc17 will be updated
---> Package perl-Pod-Simple.noarch 1:3.16-215.fc17 will be an update
---> Package perl-Test-Harness.noarch 0:3.23-212.fc17 will be updated
---> Package perl-Test-Harness.noarch 0:3.23-215.fc17 will be an update
---> Package perl-Test-Simple.noarch 0:0.98-212.fc17 will be updated
---> Package perl-Test-Simple.noarch 0 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-30 10:54:12 -0600

mattdm gravatar image

It looks like the package in the rpm-sphere repo has some file which uses /bin/perl. In Fedora, perl has always been at /usr/bin/perl. In short, the package is either not made for Fedora or broken. You could download the source RPM and fix it, or contact the packager with a bug report.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-10-30 00:33:43 -0600

Seen: 360 times

Last updated: Oct 30 '12