Ask Your Question

Help setting up xorg.conf on Fedora KDE

asked 2017-07-24 21:33:35 -0500

enzis gravatar image

updated 2017-07-26 23:43:08 -0500

SOLVED: The solution for my setup was unique as Xorg doesn't work right for me. Most users will likely get a working Xorg solution thanks to the answer below to this question. See my own solution below (using xinput) if you need an alternate solution.

Hello. I'm having trouble setting up xorg.conf on my Fedora KDE laptop. First some info then what I've tried and how it's not working. P.S. I'm a somewhat Linux newb.


  • Fedora 25 (KDE laptop) from (Model LC2500)
  • GDM 3.22.3
  • KDE Plasma: 5.9.5
  • KDE Frameworks: 5.34.0
  • Qt: 5.7.1
  • Kernel: 4.11.10-200.fc25.x86_64
  • OS: 64 bit

What I've tried:

  • Stopping lightdm, gdm, and kdm, and looks like only gdm is installed
  • The following commands, via various research:

$ sudo service gdm stop # This returns the following (not sure if it's a problem)

Redirecting to /bin/systemctl stop gdm.service

$ Xorg -configure # This returns the following

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE)
Please consult the Fedora Project support
for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.

  • As per research, I've tried the above in terminal mode, but am having problems there as well. When I press Cntrl+Alt+F1, it goes to a login, and goes right back to my desktop GUI after authentication. F2 looks like its just the GUI, so I use F3 currently. However, the same commands give the same results as above.

  • Edit: After trying the ":5" part of the marked solution, I got further but am now getting a segmentation fault. Research will continue but any help will be greatly appreciated.

Here's a snippet of the segmentation fault:

[   340.034] (II) Module ABI versions:
[   340.034]    X.Org ANSI C Emulation: 0.4
[   340.034]    X.Org Video Driver: 23.0
[   340.034]    X.Org XInput driver : 24.1
[   340.034]    X.Org Server Extension : 10.0
[   340.035] (--) using VT number 4

[   340.035] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   340.035] (II) xfree86: Adding drm device (/dev/dri/card0)
[   340.036] (EE) 
[   340.036] (EE) Backtrace:
[   340.037] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59ea19]
[   340.038] (EE) 1: /lib64/ (funlockfile+0x50) [0x7f11a65825ff]
[   340.038] (EE) 2: /usr/libexec/Xorg (xf86PlatformMatchDriver+0x2a4) [0x496f14]
[   340.039] (EE) 3: /usr/libexec/Xorg (xf86BusProbe+0x9) [0x46e8e9]
[   340.039] (EE) 4: /usr/libexec/Xorg (InitOutput+0x74a) [0x47d44a]
[   340.040] (EE) 5: /usr/libexec/Xorg (InitFonts+0x216) [0x43aea6]
[   340.041] (EE) 6: /lib64/ (__libc_start_main+0xf1) [0x7f11a61cb401]
[   340.041] (EE) 7: /usr/libexec/Xorg (_start+0x2a) [0x424d5a]
[   340.042] (EE) 
[   340.042 ...
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-07-25 11:23:30 -0500

villykruse gravatar image

Following is not a problem. systemctl stop gdm.service is just the new way of

  $ sudo service gdm stop # This returns the following (not sure if it's a problem)

    Redirecting to /bin/systemctl stop gdm.service

systemctl stop gdm.service is just the new way of running /bin/systemctl stop gdm.service, and the `service command is just nice enough to do the "right thing".

As for

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

You run Xorg using a different display number like this:

Xorg :5 -configure # This returns the following

However, when I tried it said I need to run it as root, and when I ran it as root, I got a segmentation violation.

For several years I never had to do anything with the Xorg configuration files, as the automatic configuration is good enough for me.

edit flag offensive delete link more


The response is appreciated. The reason I want an xorg.conf file is I've got a special ergonomic mouse for my arthritis and am trying to turn on and control all the buttons on it. From what I've read, it sounds like an xorg.conf file is the "correct" way to achieve this. I'll try the xorg display number when I get home.

enzis gravatar imageenzis ( 2017-07-25 12:06:26 -0500 )edit

So after trying your solution with the ":5", it got me further, but xorg had a segmentation fault. As such, if you have more time to help it will be appreciated, but otherwise I may try to work with customer support from linuxcertified as this is getting a bit "in the weeds".

enzis gravatar imageenzis ( 2017-07-25 23:48:23 -0500 )edit

In `man Xorg' it says:

               When  this option is specified, the Xorg server loads all video
               driver modules, probes for available hardware, and  writes  out
               an  initial xorg.conf(5) file based on what was detected.  This
               option **currently has some problems on some  platforms**,  but  in
               most  cases  it  is  a  good way to bootstrap the configuration
               process.  This option is only available when the server is  run
               as root (i.e, with real-uid 0).
villykruse gravatar imagevillykruse ( 2017-07-26 01:00:56 -0500 )edit

I don't have the knowledge to investigate the segmentation problem.

villykruse gravatar imagevillykruse ( 2017-07-26 01:02:19 -0500 )edit

I'll continue looking into it. Thanks for helping me with what you can.

enzis gravatar imageenzis ( 2017-07-26 09:22:03 -0500 )edit

Question Tools

1 follower


Asked: 2017-07-24 21:30:51 -0500

Seen: 467 times

Last updated: Jul 26 '17