Ask Your Question
0

Fedora 26 Touchpad enable toggle key does not work

asked 2017-07-23 05:50:39 -0600

atozer gravatar image

updated 2017-07-23 22:06:00 -0600

Hi, I have freshly installed Fedora 26 to a Lenovo Yoga 900 and I cannot get the touchpad enable/disable toggle key to work. I had the enable/disable toggle key working in Fedora 25. My process has been:

dmesg

[ 4086.176227] atkbd serio0: Unknown key pressed (translated set 2, code 0xbe on isa0060/serio0).
[ 4086.176237] atkbd serio0: Use 'setkeycodes e03e <keycode>' to make it known.
[ 4086.178078] atkbd serio0: Unknown key released (translated set 2, code 0xbe on isa0060/serio0).
[ 4086.178088] atkbd serio0: Use 'setkeycodes e03e <keycode>' to make it known.

xmodmap -pke

keycode 199 = XF86TouchpadToggle NoSymbol XF86TouchpadToggle
keycode 200 = XF86TouchpadOn NoSymbol XF86TouchpadOn
keycode 201 = XF86TouchpadOff NoSymbol XF86TouchpadOff

sudo setkeycodes e03e 191 # I read somewhere to subract 8 from xmodmap, it worked in Fed. 25. I tried 199 as well and it didn't work either.

$ sudo showkey -k

kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode  28 release
keycode 191 press      # this is when i pressed the toggle touchpad key
keycode 191 release    # this is also when i pressed the toggle touchpad key (before release)
keycode  29 press
^Ccaught signal 2, cleaning up...

$ sudo showkey -s

kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
0x9c 
0x74 0xf4             # this is when i pressed the toggle touchpad key

I am aware that the Synaptics driver has been retired for F26 (https://fedoraproject.org/wiki/Changes/RetireSynapticsDriver) and I suspect that installing the Synaptics driver may solve my issue. I would prefer not to install the Synaptics driver if it is not recommended, and it seems it is not the future.

Thank you for reading my question. Any and all help will be greatly appreciated.

edit retag flag offensive close merge delete

Comments

Run evtest (you will probably have to install it first). Find which event device is your laptop keyboard. Remember the event number for a later step. Enter the number. Press the touchpad toggle key and see if there is any output. Paste it here. Use CTRL-C to stop evtest. Run udevadm info /dev/input/event1 (replace event1 with keyboard event device) and paste that output here as well.

ssieb gravatar imagessieb ( 2017-07-24 14:21:23 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2017-07-23 22:15:47 -0600

atozer gravatar image

Note to self, try: gsettings set/get org.gnome.desktop.peripheral.touchpad... # check from dconf

Also have a read of: https://wiki.archlinux.org/index.php/Libinput

I will check it after work.

edit flag offensive delete link more
0

answered 2017-07-31 16:22:56 -0600

jawse gravatar image

Switching from Wayland to Xorg on Fedora 26 resolved this issue. Maybe its a problem with libinput on wayland.

edit flag offensive delete link more
0

answered 2017-07-31 12:54:43 -0600

jawse gravatar image

Was this resolved? I know someone who just sent me a message having the same issue.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-07-23 05:50:39 -0600

Seen: 846 times

Last updated: Jul 23 '17