Ask Your Question
0

How can I avoid old epson inkjet-drivers from preventing upgrade?

asked 2017-07-22 08:29:21 -0600

trond gravatar image

When trying to upgrade my laptop from Fedora 25 to 26, I get an error message noting conflicts between an andless series of new Epson drivers and previous installs of epson-inkjet-printer-escpr-1:1.610-2.1lsb3.2.fc25.i686 and epson-inkjet-printer-escpr-1:1.6.10-2.1lsb3.2.fc25.x86_64. These can apparently not be deleted, so it appears I'm stuck. Any suggestions?

edit retag flag offensive close merge delete

Comments

I posted my usual approach but I wonder if this can apparently not be deleted detail will prevent you from using that. Could you elaborate on why it appears that these can not be deleted? At least my F26 Workstation installation does not have them present.

muep gravatar imagemuep ( 2017-07-22 11:20:22 -0600 )edit

And where does the endless series of new Epson drivers come from? And why would you need a 32bit cups filter on a 64 bit OS?

villykruse gravatar imagevillykruse ( 2017-07-22 13:58:11 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-07-22 11:18:43 -0600

muep gravatar image

For packages that are not critical for the system to boot correctly, I would often just remove those if they seem to cause conflicts on an otherwise complex upgrade operation. F26 repositories seem to have packages with those same names available so you should be able to install them back once the upgrade operation is complete.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-07-22 08:29:21 -0600

Seen: 49 times

Last updated: Jul 22 '17