Ask Your Question
0

minimal install boot results in /dev/root does not exist

asked 2013-01-16 18:53:03 -0600

fergatron gravatar image

updated 2013-08-06 22:11:55 -0600

FranciscoD_ gravatar image

I downloaded the minimal install (netinstall) ISO to a CD-R for Fedora 18. I booted my machine and it starts the "plymouth boot screen" (whatever that is), reaches the "target basic system" and then dumps me into emergency mode with the following error:

dracut-initqueue[303]: Warning: Could not boot.
dracut-initqueue[303]: Warning: /dev/root does not exist

Can anyone help me pass this error? Thanks.

edit retag flag offensive close merge delete

Comments

Me too getting this same error

desai_amogh gravatar imagedesai_amogh ( 2013-01-18 12:01:35 -0600 )edit
1

just change label from "Fedora-18-?86x??-netinst" to USB label, mos common is "LIVE", thats all.

Ho to: 1. At boot from UBS stick press TAB key for edit parameters 2. Change the Label. 3. Press ENTER Key

LKF gravatar imageLKF ( 2013-03-22 08:55:31 -0600 )edit
1

Solved:

Change the disk/USB drive disk label to match the LABEL option or vise versa.

You can check the disk label when dracut drops you to shell by 'ls /dev/disk/by-label/'.

To change the disk label in

Linux: use e2label /dev/{device name} {name}

Windows: under Computer, right click on the drive, properties, change the name

OSX: right/control click on the drive, Get Info, change the the name

hawkeyeaz1 gravatar imagehawkeyeaz1 ( 2013-08-06 09:05:06 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-07-22 16:15:55 -0600

Kalyan gravatar image

Guys

The fix is very simple:

Run the command "lsblk -o name,mountpoint,label,size,uuid" on the server and make a note of your label name of usb drive.

Boot USB drive to install fedora 20.

After selecting Install Fedora 20, hit the tab key and replace everything after "LABEL=" with the Label name of USB drive in the same way it appears in the lsblk command.

Hit enter to install Fedora 20. we are good to install the OS.

edit flag offensive delete link more
0

answered 2013-01-16 19:18:22 -0600

I downloaded what I thought was the "full" download and get the same error on one of my PCs, yet it loads just fine on another, in fact using it right now. That said not sure why we are getting this error message.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-01-16 18:53:03 -0600

Seen: 19,052 times

Last updated: Aug 06 '13