Ask Your Question
1

Where has the logout option gone from the Fedora user menu?

asked 2013-02-19 20:52:55 -0600

ryanlerch gravatar image

updated 2014-09-12 19:44:21 -0600

mether gravatar image

In Fedora 17, there was an menu item in the user menu that allowed me to logout of Fedora. Since I updated to a newer version of Fedora, the logout option no longer appears?

Is there a way to turn it back on?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-02-19 21:00:45 -0600

ryanlerch gravatar image

updated 2014-02-18 19:45:34 -0600

Fedora 18 (GNOME 3.6) introduced some more tweaks and changes to how the User menu works. One change that may trip up regular Fedora / gnome-shell users is that, by default, the Logout option in the user menu does not appear.(the menu that drops down from your name in the top right corner of the shell).

Basically, the change (In Fedora 18 and newer) is this:

If you only have one user set up on a system, and only have one Desktop environment installed (i.e. just GNOME) then the logout option is not shown.

So, if you add another user to the system, or another Desktop environment (e.g. XFCE or KDE), the logout option will appear. (you may need to restart gnome-shell for this to take effect)

Can I Just turn it back on?

You can force the logout option to show without adding a new user or Desktop Environment, by following these steps:

  1. First open up the dconf editor (fedora package dconf-editor), and navigate to the org > gnome > shell key.

  2. Check the option always-show-log-out (pictured below in the screenshot), to always show the logout option. Note, however, that a restart of the shell or a reboot may be required for this option to start working.

image description

edit flag offensive delete link more

Comments

Is this still the suggested workaround for Fedora 20? I have enabled the setting per these instructions and have rebooted my system, but the "Logout" option simply does not exist.

Linux Freak gravatar imageLinux Freak ( 2014-01-05 08:28:47 -0600 )edit
1

Yes it applies to Fedora 20 as well. Just did it (using dconf, not dconf-editor, the editor always crashes on me) and I now see my username with a logout option below.

dconf write /org/gnome/shell/always-show-log-out true
not even a logout required. The menu entry immedately appeared after using dconf.

hno gravatar imagehno ( 2014-01-21 10:04:40 -0600 )edit

Question Tools

Stats

Asked: 2013-02-19 20:52:55 -0600

Seen: 25,129 times

Last updated: Feb 18 '14