Ask Your Question
1

SELinux is preventing gnome-shell from read access on the lnk_file. What does this mean?

asked 2017-07-08 16:52:41 -0600

micca-man gravatar image

SELinux is preventing gnome-shell from read access on the lnk_file /var/lib/dbus/machine-id. I get this alert on startup. Do I have to worry about something? Or how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-07-08 21:59:55 -0600

sideburns gravatar image

Welcome to ask.fedora. I don't use Gnome, so I don't know if this is just a regular notification, or if the SELinux Troubleshooter is opening up. If all you're getting is a notification, try opening the troubleshooter from the System submenu. Select the most recent alert and go to the Troubleshooting section. This will tell you how to correct the issue by creating a custom policy and adding it to SELinux. Follow those instructions, but remember that you'll need to use sudo on the last step to get it to work. Good luck, and let us know how it works.

edit flag offensive delete link more

Comments

villykruse gravatar imagevillykruse ( 2017-07-09 03:49:30 -0600 )edit

Add the custom policy only if you think Gnome Shell should be able to read from the lnk_file. In this case it seems to be okay but usually the hardest part is to figure out if SELinux should or should not block access.

florian gravatar imageflorian ( 2017-07-09 10:56:03 -0600 )edit

The SELinux message is indeed to cryptic for me to figure out if I should create a custom policy. It is somehow related to this bug on unplugging DC adapter from laptop. https://bugzilla.redhat.com/show_bug.... No worries then.

micca-man gravatar imagemicca-man ( 2017-07-24 15:40:33 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-07-08 16:52:41 -0600

Seen: 353 times

Last updated: Jul 08 '17