Ask Your Question
1

Remove "Alternative switch to next source" keyboard shortcut?

asked 2017-06-29 13:49:31 -0600

Isrev gravatar image

During the installation of Fedora, I set two keyboard layouts: Norwegian and English. I was asked what shortcut to define for switching keyboard layouts, and I set it to Ctrl+Shift. Now that I have installed the Atom IDE, I cannot use Atom's shortcuts such as Ctrl+Shift+A (Add new project), etc. so I went into Fedora's settings menu (Settings->Region and Language->Input Sources Options) and it said go to keyboard settings. So I go there and go to remove the shortcuts, "Alternative switch to next input source" is not in the list, just "Switch to next input source" (Super+Space). How do I remove the Ctrl+Shift shortcut? Thanks in advance :)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-06-29 14:22:03 -0600

ssieb gravatar image

Install gnome-tweak-tool if you don't have it already. Open it, go to the Typing section and it's probably the Switching to another layout options that you're looking for.

edit flag offensive delete link more
0

answered 2017-06-29 14:08:33 -0600

Isrev gravatar image

Well, it's a very non-intuitive workaround, but it's all there is since the option isn't in the keyboard shortcuts. The workaround I found was (In a terminal) xkbopts="/org/gnome/desktop/input-sources/xkb-options" (for convenience) then doing dconf read $xkbopts and type dconf write followed by the output of that minus 'grp:ctrl_shift_toggle'. However, if you only have that one (like I did) you'd still have to put empty quotes, ike so: dconf write $xkbopts "['']". Really complicated workaround for a bug, but it works now.

edit flag offensive delete link more

Comments

You could use the dconf-editor to do that a lot easier.

ssieb gravatar imagessieb ( 2017-06-29 18:39:37 -0600 )edit

Question Tools

Stats

Asked: 2017-06-29 13:49:31 -0600

Seen: 1,091 times

Last updated: Jun 29 '17