Ask Your Question
1

Keyboard stops working after login - shell works

asked 2017-06-28 15:18:42 -0600

guerda gravatar image

updated 2017-07-08 10:32:40 -0600

I have a strange problem with my USB keyboard (Logitech G15). I'm using this keyboard since several years with Fedora and since about 3 weeks, it stops working after login. I can login via the Gnome session (enter password works), but then the keyboard stops working. Until I reboot, I cannot use the keyboard anymore, not even to Ctrl+Alt + F2.

If I go to the shell before I login to Gnome, the keyboard works perfectly, on all accounts (root, main account, newly created one).

I cannot see any error message in dmesg about the keyboard (it gets detected) or journalctl.

I commented the section in /etc/X11/xorg.conf.d/00-keyboard.conf out, which states something about keyboard. No effect.

I tried different user accounts, even a newly created one. Same situation. I also tried another USB port, same situation.

Deactivating fwupd didn't help. I have experienced the same behavior as in https://github.com/hughsie/fwupd/issu... (Num lock on, then it turns off and scroll lock turns on).

Pull the keyboard out and plugging it in again after the login works. Here's the dmesg output of that event:

[  171.485156] usb 4-1: USB disconnect, device number 2
[  171.485163] usb 4-1.1: USB disconnect, device number 3
[  171.585832] usb 4-1.4: USB disconnect, device number 4
[  180.316024] usb 4-1: new full-speed USB device number 5 using ohci-pci
[  180.467046] usb 4-1: New USB device found, idVendor=046d, idProduct=c223
[  180.467054] usb 4-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  180.467058] usb 4-1: Product: G15 Keyboard Hub
[  180.469109] hub 4-1:1.0: USB hub found
[  180.471020] hub 4-1:1.0: 4 ports detected
[  180.771975] usb 4-1.1: new low-speed USB device number 6 using ohci-pci
[  180.869040] usb 4-1.1: New USB device found, idVendor=046d, idProduct=c226
[  180.869047] usb 4-1.1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  180.869051] usb 4-1.1: Product: G15 Gaming Keyboard
[  180.878168] input: G15 Gaming Keyboard as /devices/pci0000:00/0000:00:12.1/usb4/4-1/4-1.1/4-1.1:1.0/0003:046D:C226.0008/input/input22
[  180.930564] hid-generic 0003:046D:C226.0008: input,hidraw2: USB HID v1.10 Keyboard [G15 Gaming Keyboard] on usb-0000:00:12.1-1.1/input0
[  180.942139] input: G15 Gaming Keyboard as /devices/pci0000:00/0000:00:12.1/usb4/4-1/4-1.1/4-1.1:1.1/0003:046D:C226.0009/input/input23
[  180.994418] hid-generic 0003:046D:C226.0009: input,hiddev0,hidraw3: USB HID v1.10 Device [G15 Gaming Keyboard] on usb-0000:00:12.1-1.1/input1
[  181.064031] usb 4-1.4: new full-speed USB device number 7 using ohci-pci
[  181.164072] usb 4-1.4: New USB device found, idVendor=046d, idProduct=c227
[  181.164079] usb 4-1.4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  181.164084] usb 4-1.4: Product: G15 GamePanel LCD
[  181.188302] input: G15 GamePanel LCD as /devices ...
(more)
edit retag flag offensive close merge delete

Comments

Plug the keyboard in a different usb port, and see.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-06-28 17:31:20 -0600 )edit

The same effect occurs on a different USB port.

guerda gravatar imageguerda ( 2017-07-04 05:31:03 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-07-04 05:52:37 -0600

Aeyoun gravatar image

Does the problem also happen if you use another keyboard? There are some recent reports of fwupd (firmware update daemon) causing issues for wired Logitech gaming keyboards. You can try to disable the fwupd service and reboot: systemctl disable fwupd && reboot.

Related issues:

edit flag offensive delete link more

Comments

Currently I don't have any other keyboard at hand, but I will try to disable fwupd and report back. Thank you.

guerda gravatar imageguerda ( 2017-07-07 04:48:39 -0600 )edit

Disabling fwupd didn't help. It's the same behavior. Do you have any pointers, where I'd can look for error messages?

guerda gravatar imageguerda ( 2017-07-07 12:40:50 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-06-28 15:18:42 -0600

Seen: 787 times

Last updated: Jul 08 '17