Ask Your Question
0

Packages conflict i686 and x86_64 versions while installing wine [solved]

asked 2017-06-24 11:57:09 -0600

ghislain gravatar image

updated 2017-06-26 02:09:57 -0600

Hi! I'm using fedora24 and facing difficulties to install wine.

I get the following error messages :

file /usr/share/doc/libjpeg-turbo/ChangeLog.md from install of libjpeg-turbo-1.5.0-4.fc24.i686 conflicts with file from package libjpeg-turbo-1.5.0-1.fc24.x8664 file /usr/share/doc/krb5-libs/README from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-6.fc24.x8664 file /usr/share/man/man5/k5identity.5.gz from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-6.fc24.x8664 file /usr/share/man/man5/k5login.5.gz from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-6.fc24.x8664 file /usr/share/man/man5/krb5.conf.5.gz from install of krb5-libs-1.14.4-4.fc24.i686 conflicts with file from package krb5-libs-1.14.3-6.fc24.x8664 file /usr/share/doc/libtasn1/NEWS from install of libtasn1-4.9-1.fc24.i686 conflicts with file from package libtasn1-4.8-2.fc24.x8664 file /usr/share/doc/libtasn1/libtasn1.pdf from install of libtasn1-4.9-1.fc24.i686 conflicts with file from package libtasn1-4.8-2.fc24.x8664 file /usr/share/doc/pango/NEWS from install of pango-1.40.3-1.fc24.i686 conflicts with file from package pango-1.40.1-1.fc24.x8664 file /usr/share/man/man1/pango-view.1.gz from install of pango-1.40.3-1.fc24.i686 conflicts with file from package pango-1.40.1-1.fc24.x86_64

Apparently the 32bits version conflicts the 64bits one. I tried to check on the internet to find what was going on, but no solutions worked... I tried to downgrade the packages but they are already the lowest version.

Apparently the bug has already been reported link:[https://bugzilla.redhat.com/show_bug.cgi?id=1366516]

Does anyone has an idea of how I could install wine please?

Thank you for your help!

Ghislain

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-25 03:15:42 -0600

villykruse gravatar image

updated 2017-06-25 03:16:27 -0600

The usual cause is that the system is not up-to-date. Current versions of the conflicting packages are:

krb5-libs-1.14.4-4.fc24.i686.rpm
krb5-libs-1.14.4-4.fc24.x86_64.rpm
libjpeg-turbo-1.5.0-4.fc24.i686.rpm
libjpeg-turbo-1.5.0-4.fc24.x86_64.rpm
libtasn1-4.9-1.fc24.i686.rpm
libtasn1-4.9-1.fc24.x86_64.rpm
pango-1.40.3-1.fc24.i686.rpm
pango-1.40.3-1.fc24.x86_64.rpm

To fix the issue, run dnf upgrade.

edit flag offensive delete link more

Comments

I couldn't upgrade the packages, so I tried upgrading the whole system to fedora25 and now it works! Thank you!

ghislain gravatar imageghislain ( 2017-06-26 02:07:33 -0600 )edit

Question Tools

Stats

Asked: 2017-06-24 11:57:09 -0600

Seen: 540 times

Last updated: Jun 26 '17