Ask Your Question
0

error installing R

asked 2017-06-14 08:16:14 -0600

Raffaello gravatar image

updated 2017-06-15 04:14:37 -0600

this is the error:

sudo dnf install R
Last metadata expiration check: 0:02:04 ago on Wed Jun 14 13:55:14 2017.
Error: package R-core-3.3.1-2.fc25.x86_64 requires libRmath(x86-64) = 3.3.1-2.fc25, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

I think it is a package missing/conflicts. I think I cannot do nothing.

EDIT

dnf repolist

Last metadata expiration check: 0:01:44 ago on Thu Jun 15 10:11:49 2017.
repo id                                                                                 repo name                                                                                                            status
epel                                                                                    Extra Packages for Enterprise Linux 7 - x86_64                                                                       11,790
*fedora                                                                                 Fedora 25 - x86_64                                                                                                   51,669
google-chrome                                                                           google-chrome                                                                                                             3
remi-php71                                                                              Remi's RPM repository - PHP 7.1 - Fedora 25 - x86_64                                                                    328
*rpmfusion-free                                                                         RPM Fusion for Fedora 25 - Free                                                                                         541
*rpmfusion-free-updates                                                                 RPM Fusion for Fedora 25 - Free - Updates                                                                               201
slack                                                                                   slack                                                                                                                    29
*updates                                                                                Fedora 25 - x86_64 - Updates                                                                                         19,989
virtualbox                                                                              Fedora 25 - x86_64 - VirtualBox                                                                                           7

Any suggestion?

edit retag flag offensive close merge delete

Comments

Can you give us the output from the

dnf repolist

Current version, by the way, is 3.3.3-1.fc25

villykruse gravatar imagevillykruse ( 2017-06-14 14:52:18 -0600 )edit

added the repolist to the answer.

Raffaello gravatar imageRaffaello ( 2017-06-15 04:15:11 -0600 )edit

current version of libRmath do you mean? or R ?

Raffaello gravatar imageRaffaello ( 2017-06-15 04:20:00 -0600 )edit
1

"epel" should not be in the list. If is meant for centos or RHEL for things which are already provides by fedora, but not by centos or RHEL.

villykruse gravatar imagevillykruse ( 2017-06-15 04:50:44 -0600 )edit

this seems a good clue. i am going to check it.

Raffaello gravatar imageRaffaello ( 2017-06-15 06:07:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-06-15 04:57:01 -0600

villykruse gravatar image

I see you include "epel" in the list of repository. This repository is not compatible with fedora, and is only meant for use nu RHEL and Centos systems. "epel" is a repository for things which are on included be RHEL, but could be useful.

Including epel on a fedora system can be enough to cause package conflicts.

edit flag offensive delete link more

Comments

ok that repo I think what was causing the package conflict. Combined to the other answer using --allowerasing i do not have anymore the package conflict.

Raffaello gravatar imageRaffaello ( 2017-06-15 06:10:41 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-06-14 08:16:14 -0600

Seen: 149 times

Last updated: Jun 15 '17