Ask Your Question
1

How to use Gnome-documents to see local docs ?

asked 2011-11-29 10:44:36 -0600

adams gravatar image

updated 2011-11-30 08:44:18 -0600

Hi. I want to use gnome-documents app to manage all documents in my laptop but I can't find how it works. It shows documents saved in my google account only. Of course that I chose to show only local docs but still it shows nothing. I want use it to manage especially local docs. Most of documents I've got saved in Documents folder in my home directory. Is there any way how can I set in which directory the application will seek my local docs?

Thanks for your answers.

UPDATE

I still have this problem but I found that in file ~/.local/share/tracker/tracker-extract.log after every restart of tracker control (tracker-control -rs) is added more than 3500 lines of warnings and calls. First 15 lines are these:


30 lis 2011, 15:21:11: Tracker-Warning **: Call to gstdiscovererdiscover_uri() failed: Stream has no data.

30 lis 2011, 15:21:12: Tracker-Warning **: Cannot read from FD... could not extract text

30 lis 2011, 15:21:21: Tracker-Warning **: Could not get pixbuf from GdkPixbufLoader when setting album art

30 lis 2011, 15:21:21: Tracker-Warning **: Could not get pixbuf from GdkPixbufLoader when setting album art

30 lis 2011, 15:21:21: Tracker-Warning **: Could not get pixbuf from GdkPixbufLoader when setting album art .....


and it continues repeating these three lines:


30 lis 2011, 15:21:30: GLib-GIO-Critical **: gfilenewforpath: assertion `path != NULL' failed

30 lis 2011, 15:21:30: GLib-GIO-Critical **: gfileread: assertion `GISFILE (file)' failed

30 lis 2011, 15:21:30: GLib-GObject-Critical **: gobjectunref: assertion `GISOBJECT (object)' failed


Maybe somebody of you knows what does it mean and could help me with the problem. Or it is a bug and I do nothing :) Thank you.

edit retag flag offensive close merge delete

Comments

which version do you have? Works for me without google account configured. (v. 0.2.1). Sounds like a bug to me, consider reporting

shaiton gravatar imageshaiton ( 2011-11-29 11:01:09 -0600 )edit

@adams gnome-documents is at really early stage, bugs should be reported! Please do so at the GNOME upstream bugzilla against the gnome-documents component.

shaiton gravatar imageshaiton ( 2011-11-30 08:50:03 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-29 12:26:52 -0600

thunderbirdtr gravatar image

updated 2011-11-29 12:48:56 -0600

It's not bug just Fedora not come with installed all you need just ;

Open terminal

su -c'yum -y install gnome-documents'

Aftar that do this but not with root use your user in terminal

tracker-control -s

And Open your application you will see "Documents" Application open it And now you can look your google document

But If you want to import to your LibreOffice , You add a add-on for libreoffice

su -c 'yum install ooo2gd'

And done If you open your libreoffice you will see 'google document tool'

One more thing for gnome-documents ;

https://live.gnome.org/Design/Apps/Documents

edit flag offensive delete link more

Comments

It is a bug for me, as it should provide you all documents, not only the google ones.

shaiton gravatar imageshaiton ( 2011-11-29 13:20:50 -0600 )edit
0

answered 2011-11-29 13:25:26 -0600

shaiton gravatar image

updated 2011-11-29 13:26:14 -0600

As explained in the arch wiki try the following:

xdg-user-dirs-update
tracker-control -rs

That should solve the problem. Please let us know or report on bugzilla if that works, you should not need to update it manually.

edit flag offensive delete link more

Comments

do you have XDG_DOCUMENTS_DIR="$HOME/Documents" in the ~/.config/user-dirs.dirs file?

shaiton gravatar imageshaiton ( 2011-11-29 14:50:12 -0600 )edit

Question Tools

Stats

Asked: 2011-11-29 10:44:36 -0600

Seen: 5,139 times

Last updated: Nov 30 '11