Ask Your Question
0

iio-sensor

asked 2017-05-31 11:06:37 -0600

msir99 gravatar image

I am experiencing long pauses when trying to wake my laptop after suspend. It often takes > 30 sec of tapping on the keyboard and swiping on the trackpad to get the display to turn on. At that point my password text box is filled with characters. I also experience a large delay when i select Settings > Displays, the display number appears in the corner of the screen immediately but the dialog box takes > 30 sec to change to the Displays panel.

After mucking around I found that by stopping the iio-sensor-proxy service (systemctl stop iio-sensor-proxy.service) these pauses go away and everything seems to work fine. I cannot disable the iio-sensor-proxy from starting at boot with (systemctl disable iio-sensor-proxy.service) it starts anyway. I cannot remove it from my system because it is a dependency for many packages.

  • Is there a way to troubleshoot what seems like a timeout issue with iio-sensor-proxy?
  • Is there a way I can just get rid of iio-sensor-proxy?

The command monitor-sensor gives the following output: $ monitor-sensor

Waiting for iio-sensor-proxy to appear +++ iio-sensor-proxy appeared


ERROR:monitor-sensor.c:165:appeared_cb: assertion failed (error == NULL): Timeout was reached (g-io-error-quark, 24) Aborted (core dumped)

My computer is a Samsung Notebook 9 Spin 940X3L-K01 $ uname -r 4.10.17-200.fc25.x86_64

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-03-01 22:16:08 -0600

After mucking around I found that by stopping the iio-sensor-proxy service (systemctl stop iio-sensor-proxy.service) these pauses go away and everything seems to work fine. I cannot disable the iio-sensor-proxy from starting at boot with (systemctl disable iio-sensor-proxy.service) it starts anyway. 9apps

edit flag offensive delete link more
0

answered 2017-05-31 14:44:23 -0600

msir99 gravatar image

I can answer one part of this question: In order to completely stop iio-sensor-proxy from loading at boot "systemctl disable" does not work, iio-sensor-proxy will still start. From THIS THREAD need to use the mask command:

$ systemctl mask iio-sensor-proxy.service

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-05-31 11:06:37 -0600

Seen: 821 times

Last updated: May 31 '17