Ask Your Question
0

Poor Intel HD Graphics 2000 Performance

asked 2017-05-30 17:28:36 -0600

manguza gravatar image

updated 2017-05-30 23:46:26 -0600

I'm currently having very noticeable graphical issues both in both 2D and 3D "environments" on either Wayland or X, and previously screen tearing in X, in a clean Fedora 25 GNOME updated installation, that i don't experience in either Windows 10 or Ubuntu 17.04.

I'm most hopeful to solve these issues at least in X. My processor is a i5 2500 ( Sandybridge ) and it has a Intel HD Graphics 2000 integrated GPU. Out of the box GNOME on Wayland doesn't has any screen tearing in contrary to X, but as well as in X, windows seem to move slightly "slowly", as if they my screen refresh rate was slower, this is noticeably worse is Wayland. On X or Waland, in either Firefox ( with or without the flag to force acceleration enabled ) or Chrome pages scroll noticeably slowly, and CSS/JS animations play in a very low frame rate. Steam's games such as Half Life 2 has much stuttering and runs in very low FPS in Wayland but runs almost completely fine in X but still occasionally stutters.

As i said, these problems don't happen in either Ubuntu or Windows. I've looked through the Arch and Fedora forums and some other places for help but i can't seem to find any solid clue on how to fix this, and up until now i have only found enough useful information to be able to try different xorg.conf.d options through 20-intel.conf, through with this, i have only manage to solve the screen tearing issue in X.

I greatly appreciate any guidance. Link to my Xorg.0.log file. and glxinfo output.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "SwapbuffersWait"  "true"
   Option      "TearFree"    "true"
EndSection

lsmod | grep "kms\|drm"
drm_kms_helper        155648  1 i915
drm                   352256  12 i915,drm_kms_helper

find /dev -group video
/dev/fb0
/dev/dri/card0
/dev/dri/renderD128

glxinfo | grep -i "vendor\|rendering"
direct rendering: Yes
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
Vendor: Intel Open Source Technology Center (0x8086)
OpenGL vendor string: Intel Open Source Technology Center

grep LoadModule ~/.local/share/xorg/Xorg.0.log
[  7567.353] (II) LoadModule: "glx"
[  7567.354] (II) LoadModule: "intel"
[  7567.356] (II) LoadModule: "dri3"
[  7567.356] (II) LoadModule: "dri2"
[  7567.356] (II) LoadModule: "present"
[  7567.408] (II) LoadModule: "libinput"

Update: I've tried enabling modesetting by setting my 20-inte.conf to the text below, but i've experienced no peformance difference. I've just noticed that GDM shows a black screen for a very quick period of time before the GNOME DE actually appears instead of smoothly transitioning once i log in.

Section "Device"
       Identifier  "Intel Graphics"
       Driver      "modesetting"
EndSection
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-03 15:32:46 -0600

Sirber gravatar image

Best not use: Option "TearFree" "true"

with desktops that use a compositor, like gnome or wayland. TearFree is like a compositor, so you compositor twice and lower performance.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-30 17:23:12 -0600

Seen: 596 times

Last updated: May 30 '17