Ask Your Question
2

Fedora25: mouse problem with KVM Guest consoles

asked 2017-05-30 16:47:23 -0600

martinh gravatar image

On my HP Zbook laptop (I7, 32GB) I was running Fedora24 and KVM to support a few virtual machines: a couple of CentOS servers and workstations, a few Windows7 workstations and one Windows10 workstation. Most VM's run well and the mouse can be used to switch from console window(VM) to console window(VM) connecting mouse and keyboard to the active Window. Except for the Windows10 VM, There I had to release the mouse/keyboard using [Ctrl]+[Alt] when I want to get out. Inconsequent but a minor issue I could live with.

After upgrading to Fedora25 however this (Windows 10) behaviour got worse. When this VM is active I now see two mouse cursors, One bound to the VM console window and one detached from the VM. Moving the mouse the cursors both move, but not quite the same. One is faster, clipping (of course) is different and when the 'detached' cursor is at the screen border the other cursor stops as well. Another problem is that clicking seems to be active inside the VM console window as well as outside that window, effectively doubling the click action. Efficient, but very difficult to use effectively :-).

Anyone knows this behaviour and even better, knows how to solve this ? As a workaround I currently use a separate USB mouse/keyboard passed through to the Windows10 VM.

Of course I retrieved the latest virtio drivers and installed them in Windows10 but that didn't help. Also tried to remove and reinstall windows drivers competely. But even in full screen mode I get these two cursors.

PM: Just started an Ubuntu16.04 (Workstation) VM, That seems to have the same problem. Haven't (yet) got a chance to investigate that further.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-31 14:50:47 -0600

jmt gravatar image

Windows virtual machines work better through rdesktop.

Personally I use a script which ends with the following command:

desktop ${addr} -u ${user} -k fi -g ${width}x${height} -a $colordepth -x lan -r sound:local

(Note that I have a Finnish keyboard -k fi)

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2017-05-30 16:47:23 -0600

Seen: 293 times

Last updated: May 31 '17