Ask Your Question

VirtualBox not displaying 64-bit

asked 2017-05-26 13:19:52 -0600


New to fedora, I've installed VirtualBox using :

dnf install VirtualBox.x86_64

Then I tried to launch VM using :


But I got an error message saying I had to run :

dnf install akmod-VirtualBox kernel-devel-4.8.6-300.fc25.x86_64
akmods --kernels 4.8.6-300.fc25.x86_64 && systemctl restart systemd-modules-load.service

which I did.

So now VM is launching. But when I try to create a virtual OS, VM is only displaying 32-bit versions.

How can I make VM display also 64-bit versions ?

Thinkpad X230 / Fedora 25 / Memory: 7.5G / Processor i5-3320 CPU (2.60x4) / OS: 64-bit / Intel Ivybridge Mobile / Gnome 3.22.2

edit retag flag offensive close merge delete


I enabled the VT in the BIOS and it worked. Thank you very much !

kaha987 gravatar imagekaha987 ( 2017-05-27 03:26:16 -0600 )edit

awesome :) please mark my answer.

jlozadad gravatar imagejlozadad ( 2017-05-27 08:20:54 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-05-26 14:34:40 -0600

can you verify the ISO you are using are 64 bit and the VT is enabled in your BIOS/EFI?

edit flag offensive delete link more

Question Tools


Asked: 2017-05-26 13:19:52 -0600

Seen: 643 times

Last updated: May 26 '17