Ask Your Question
3

Claim device VFIO in stead of Nvidia

asked 2017-05-17 14:24:38 -0500

florius gravatar image

Hi,

I'm trying to setup GPU passthrough on Fedora 25. I have 2 cards, a GTX1050 for the host and a GTX980. I use the nvidia drivers but I can't get VFIO to claim the GTX980.

# cat /etc/modprobe.d/local.conf 
options vfio-pci ids=10de:13c0,10de:0fbb

My local.conf, and I'm sure my device ID's are correct. But nvidia claims it before vfio can... Can someone help me out?

edit retag flag offensive close merge delete

Comments

does nobody have resolved this already? I have the same problem I had to blacklist nouveau, but still vfio are not loading

boistordu gravatar imageboistordu ( 2018-07-21 11:26:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-07-23 08:00:35 -0500

boistordu gravatar image

I have the answer to your question.

You need to install dracut. if not already done.
after that, in one of the conf, or a new conf you declare nouveau as blacklisted for the GTX980. I didn't find the right command yet and maybe you can ignore this step but just in case... after that you need to do sudo dracut -f --add-drivers vfio --add-drivers vfio-pci --add-drivers vfio_iommu_type1 --add-drivers vfio_virqfd because apparently noone have find out the right command yet to load specific drivers from the conf, maybe it's dracut version related but anyway none of the:

softdep nvidia pre: vfio vfio_iommu_type

GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap intel_iommu=on rd.driver.pre=vfio-pci rhgb quiet"

does work to tell dracut to install vfio drivers. So you need to do it manually by adding parameters to dracut command.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-17 14:24:38 -0500

Seen: 653 times

Last updated: Jul 23 '18