Why is gnome calculator using the wrong locale settings?

asked 2012-07-12 03:56:13 -0500

wis775 gravatar image

updated 2012-09-02 03:00:02 -0500

I use Fedora with the following settings for the locales (Regions and Language):

  • Language: English
  • Formats: Austria
  • Layouts: German(Austria)

All is like expected. E.g. I see the date in the German format, Nautilus shows the file sizes with the German format.

But the Gnome Calculator doesn't honor my format settings. For the decimal separator, the Gnome Calculator is still expecting the dot instead of a comma. But this vary on the way, I launch gcalctool

  • Using the keybord shortcut: Dot as decimal separator
  • Using the application menu: Comma as decimal separator
  • Start gcalctool via the alt+F2: Comma as decimal separator
  • Start gcalctool via terminal: Comma as decimal separator

So, why I will get a Dot as decimal separator if I start gcalctool via the keyboard shortcut?

edit retag flag offensive close merge delete