Ask Your Question
0

php.ini not working

asked 2017-05-08 17:49:15 -0600

bionan2017 gravatar image

I installed php 5.4 from the remi's repository.

I activated this version of php (module load php54).

I changed the php.ini file located in /opt/remi/php54/root/etc, activating displayerrors (displayerrors = on) and restarted the apache server (sudo service httpd start).

However when running phpinfo() the displayerrors option appears disabled (displayerrors = off).

Any idea what's going on? Thanks for any help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-05-09 03:54:37 -0600

Rabin gravatar image

One way to find/confirm the php.ini used by the server is to look in the phpinfo() out put and see the path for the php.ini in used.

Also it common best practice not to change the php.ini directly, but to overwrite it settings using files in /etc/php.d/ or in the case of this SCL /opt/remi/php54/root/etc/php.d

edit flag offensive delete link more

Comments

Thank you, Rabin Your sugestion to not change the php.ini directly, but to overwrite it settings using files in /etc/php.d/ or in the case of this SCL /opt/remi/php54/root/etc/php.d, solved the problem!

bionan2017 gravatar imagebionan2017 ( 2017-05-09 04:19:21 -0600 )edit
0

answered 2017-05-11 14:10:14 -0600

genodeftest gravatar image

PHP version 5.4 has been out of support for 1.5 years. If someone still provides this outdated software, don't expect they care about software quality at all. Use a more recent version of PHP instead.

edit flag offensive delete link more

Comments

Not every one can upgrade freely to the newest version of PHP, some times your limited by the software stack you have.

Rabin gravatar imageRabin ( 2017-05-11 15:57:41 -0600 )edit

The problem is precisely the need to run software that is incompatible with php 7 ... hence the need to install an outdated version of PHP.

bionan2017 gravatar imagebionan2017 ( 2017-05-11 16:44:23 -0600 )edit

If someone still provides this outdated software, don't expect they care

=> of course I recommend using a maintained version (>=5.6), BTW 5.4 in my repo is maintained (security fix only), see https://blog.remirepo.net/post/2015/1...

remi gravatar imageremi ( 2017-05-12 05:37:47 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-05-08 17:49:15 -0600

Seen: 1,002 times

Last updated: May 11 '17