Ask Your Question
0

tmpfs: command not found

asked 2017-05-04 21:56:31 -0600

brunrozendo gravatar image

I'm trying to run the following command

[root@fedora bruno]# tmpfs /opt/jdk tmpfs defaults,mode=1777 0 0

But a get this output

bash: tmpfs: command not found

To me its odd becouse of this

root@fedora bruno]#  df -h
Sist. Arq.               Tam. Usado Disp. Uso% Montado em
devtmpfs                 1,9G     0  1,9G   0% /dev
tmpfs                    1,9G     0  1,9G   0% /dev/shm
tmpfs                    1,9G  1,3M  1,9G   1% /run
tmpfs                    1,9G     0  1,9G   0% /sys/fs/cgroup
/dev/mapper/fedora-root   50G  8,0G   39G  18% /
tmpfs                    1,9G   28K  1,9G   1% /tmp
/dev/sda1                976M  174M  736M  20% /boot
/dev/mapper/fedora-home  240G   16G  212G   8% /home
tmpfs                    375M   16K  375M   1% /run/user/1000

I using Fedora Lxde 25

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2017-05-04 23:52:22 -0600

florian gravatar image

updated 2017-05-05 00:07:41 -0600

Boa noite amigo, what are you trying to do? The command tmpfs does not exists. tmpfs describes a filesystem/storage facility that resides in memory, and will be cleared with a reboot.

In my opinion, the "command" that you are writing there should be part of /etc/fstab. That way you can relocate a file/directory from disk to RAM (and swap). I use this scenario to place /tmp to RAM, and you could to the same with /opt/jdk.

my fstab line looks like this:

none             /tmp/                      tmpfs   size=8% 0 0

You can use your tweak to relocate /opt/jdk to RAM in order to improve performance. Just place the following to /etc/fstab and reboot...

tmpfs /opt/jdk tmpfs defaults,mode=1777 0 0

... but be aware, anything in /opt/jdk will be cleared on each reboot.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-04 21:49:31 -0600

Seen: 1,025 times

Last updated: May 05 '17