Ask Your Question
0

GPG error in installing R studio on Fedora 25

asked 2017-05-02 10:10:33 -0600

gav888 gravatar image

Hi there, I have Fedora Scientific installed and I am trying to install R Studio 1.43 using the rpm package from the Rstudio webpage. However, opening the package with the software manager returns a "Bad GPG signature" error. Any solution? Many thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-05-02 14:36:23 -0600

florian gravatar image

Did you also download a .gpg file to verify?

Anyway, I recommend using dnf to install the package:

sudo dnf install /path/to/rstudio-file.rpm, and if you want to skip signature check, you add a --nogpgcheck. So it may look like this sudo dnf --nogpgcheck install ~/Downloads/rstudio-file.rpm

edit flag offensive delete link more

Comments

Signature check is there for a reason: To protect users from software being tampered with on servers or during download. Therefore, I strongly suggest not ignoring the GPG error. Instead, try importing the GPG key. If that still does not work, the RPM might be manipulated and should not be used.

genodeftest gravatar imagegenodeftest ( 2017-05-11 14:53:56 -0600 )edit

Good luck finding the GPG key. Maybe they can send it to you?!

florian gravatar imageflorian ( 2017-05-12 09:18:11 -0600 )edit
0

answered 2017-05-11 14:52:11 -0600

genodeftest gravatar image

I guess the error message is caused by a missing GPG key. Please make sure to import the GPG key first that was used to sign the "R studio" RPM.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-02 10:10:33 -0600

Seen: 676 times

Last updated: May 11 '17