User not shown on LightDM login screen (uid 500 or < 1000), how to show user in LightDM on Fedora 25

asked 2017-05-02 03:38:58 -0600

basic6 gravatar image

User accounts for regular desktop users (as opposed to system users) usually have a uid of 1000 or higher. In this case, the minimum is 500.

The main user account on this Fedora 25 has the uid of 500 (for historical reasons). LightDM is used as display manager. LightDM does not show this main user, instead it shows a text box for the username in addition to that for the password. It's annoying to have to type the username on every login. Where's the setting to make LightDM show this user on the login screen?

Side note: When switching to GDM, it doesn't show the user either.

What has been done: The minimum user id for regular users has been set to 500.

# grep 'ID' /etc/login.defs
UID_MIN                  500
UID_MAX                 60000
SYS_UID_MIN               201
SYS_UID_MAX               499
GID_MIN                  500
GID_MAX                 60000
SYS_GID_MIN               201
SYS_GID_MAX               499

LightDM is set to not hide the user list.

# grep -R greeter-hide-users /etc/lightdm/
/etc/lightdm/lightdm.conf:# greeter-hide-users = True to hide the user list
/etc/lightdm/lightdm.conf:greeter-hide-users=false

In case LightDM is not using the system-wide login.defs, the uid minimum has been defined in users.conf as well.

# grep -Ri UID /etc/lightdm/
/etc/lightdm/users.conf:# minimum-uid = Minimum UID required to be shown in greeter
/etc/lightdm/users.conf:minimum-uid=500

Version:

# cat /etc/fedora-release 
Fedora release 25 (Twenty Five)
# rpm -q lightdm
lightdm-1.18.3-1.fc25.x86_64
edit retag flag offensive close merge delete