Ask Your Question
1

Fedora 26 Won't Boot if USB 3.0 Hub is Connected

asked 2017-05-01 12:10:03 -0600

steve99 gravatar image

updated 2017-08-10 15:04:08 -0600

My Fedora 26 hangs with the Fedora Boot Logo when booting from the internal hard drive if a USB 3.0 Hub with nothing plugged into it it is connected to the computer. This Dell M2800 laptop in a Dell e-Port Plus docking station is set up to multi-boot Fedora, Windows 10 and Windows 8.1. All are on the laptop's internal hard drive, not a drive through the Hub and nothing is connected to the USB 3.0 Hub. The Grub boot loader comes up fine and I can select Fedora, but then Fedora hangs with its logo on the screen. If I unplug the hub during the hang, the boot continues correctly. If I boot either Windows OS first and then boot Fedora it does not hang. In Windows, I had a problem with the hub not working in Windows 8.1 and 10, but turning off Power Save Mode in the device drivers solved that. Windows did not have a problem booting though. Is the problem in Fedora a Power Save Mode in the hub and it doesn't respond to Fedora when it boots? Is this a bug in the Fedora USB drivers?

How do I get Fedora to boot from power off with the USB Hub connected? I should not have to unplug the Hub every time I boot Fedora from a powered off system.

UPDATE:
I've tried several different brand USB 3.0 hubs and all had the same problem.
I see the following error messages during boot:
can't read hub descriptor (err -22)
hub 4-3.1:1.0: config failed, can't read hub descriptor (err -22)

Thanks in advance for any help on this.

edit retag flag offensive close merge delete

Comments

1

When you look at dmesg or journalctl -b, is there anything related to that USB hub? Do you see any error messages or warnings?

genodeftest gravatar imagegenodeftest ( 2017-05-11 15:08:06 -0600 )edit

Two questions: have you tried using a different cable, and have you tried plugging the hub into a different port?

sideburns gravatar imagesideburns ( 2017-05-25 13:13:37 -0600 )edit

I see USB references in Journalctl -b output, but no specific USB hub errors. In dmesg, I see the following errors: [ 4.055971] hub 3-13.3.1:1.0: USB hub found [ 4.056020] hub 3-13.3.1:1.0: 4 ports detected [ 4.131038] usb 3-4.2: new full-speed USB device number 12 using xhci_hcd [ 4.131265] usb 3-4.2: Device not responding to setup address. [ 4.334193] usb 3-4.2: Device not responding to setup address. [ 4.541961] usb 3-4.2: device not accepting address 12, error -71

steve99 gravatar imagesteve99 ( 2017-05-25 13:26:13 -0600 )edit

Yes, I have tried different cables and I have tried plugging the hub into a different port. Neither make any difference. Note that with Windows 8.1 and Windows 10 which I multi-boot on the same machine, I don't have the problem.

steve99 gravatar imagesteve99 ( 2017-05-25 13:28:37 -0600 )edit

Thank you for confirming that. I've seen a few cases where one OS is more tolerant about minor cabling glitches than another and wanted to make sure.

sideburns gravatar imagesideburns ( 2017-05-25 14:01:13 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2017-05-02 14:53:44 -0600

not sure what is exactly the problem but, you might have to disconnect the hub when using Fedora. Do you use the hub for anything when using fedora?

edit flag offensive delete link more

Comments

Yes I do use it for flash and hard drives. I should not have to unplug the Hub every time I boot Fedora from a powered off system.

steve99 gravatar imagesteve99 ( 2017-05-05 11:25:41 -0600 )edit

its hard to help troubleshoot the equipment since I do not not have it but, it if you keep unplugging the hub and it continues the boot process then the hub is the problem. You will have to unplug it when you use fedora.

jlozadad gravatar imagejlozadad ( 2017-05-07 15:48:14 -0600 )edit

Since both Windows 10 and 8.1 boot fine, I believe that it is a driver problem in Fedora, not a hub problem. I've tried several different brand USB 3.0 hubs, and the all had the same problem.

steve99 gravatar imagesteve99 ( 2017-05-08 11:11:44 -0600 )edit
1

Just for grits and shins, try this. go to motherboard bios, disable c1e (might be shown as cool and quiet, or some other automatic power control) and see if that helps.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-05-28 21:58:50 -0600 )edit
0

answered 2017-06-14 18:17:29 -0600

capt gravatar image

I usually just start the boot manager (f2 or Fn 12 ) or ( fn 2 or fn 12) and select the disk I want to boot from.

edit flag offensive delete link more
0

answered 2017-08-12 08:34:33 -0600

I was having similar problem, the issue was that my motherboard was trying to boot from:

EFI: Adata xxx

and I had to boot from:

Adata xxx

Hope this solve your issue

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2017-05-01 12:10:03 -0600

Seen: 867 times

Last updated: Aug 10 '17