Ask Your Question
1

512mb ram which fedora

asked 2012-04-08 00:50:19 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Howdy

Older PC with only 512mb (SDram) which I want to use as primarily IMAP & DHCP server.

Which version of fedora can run GUI in only 512mb of memory ?

With thanks

Chris g.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2012-04-09 13:27:40 -0600

Akshay gravatar image

updated 2012-04-09 13:31:54 -0600

although the system requirements for fedora 16 is 700 MB and if you try to install it on 512 MB ram it will give you an error but here is the little tweak which will let you install lxde on 512 ram vi /usr/sbin/anaconda

search for neededram = int((isys.MINRAM + extra_ram) / 1024) change that to

neededram = 0 # int((isys.MINRAM + extra_ram) / 1024)

or needed_ram = 0

click the "install to hard disk" button.

edit flag offensive delete link more
1

answered 2012-04-09 07:43:42 -0600

FranciscoD_ gravatar image

The anaconda team is working on reducing the RAM required to run the Fedora installer (anaconda). Currently, the RAM requirements of the installer are around 700MB iirc. http://docs.fedoraproject.org/en-US/Fedora/16/html/ReleaseNotes/sect-ReleaseNotes-WelcometoFedora16.html#sect-ReleaseNotes-Hardware_Overview

You can't install Fedora on a system with less than 700MB ram at the moment. You'll have to increase the RAM for the installation temporarily, as a work around.

Once installed, LXDE etc. run well on 512MB RAM :)

edit flag offensive delete link more

Comments

@ztank1013 a little tweak and it worked :)

Akshay gravatar imageAkshay ( 2012-04-09 13:28:27 -0600 )edit
1

answered 2012-04-08 04:14:24 -0600

ztank1013 gravatar image

I would try with f14 (or earlier verisions). Based on release notes you can find minimal h/w requirements:

f16 requirements

f15 requirements

f14 requirements << Minimum RAM for graphical: 384 MiB

Another test I would try is installing a later one (f15, f16, f17 beta) but with a lighter desktop environment (Xfce or Lxde). Look in Spin page.

edit flag offensive delete link more
1

answered 2012-04-08 11:28:19 -0600

Akshay gravatar image

updated 2012-04-08 11:28:34 -0600

i recommend you to download fedora 16 LXDE works real good on old pc's http://spins.fedoraproject.org/lxde/ its better to use newer versions then using old fedora GNOME versions

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-04-08 00:50:19 -0600

Seen: 5,675 times

Last updated: May 09 '14