F24 will not remote into vnc server, how to solve

asked 2017-04-12 17:20:06 -0600

jim999 gravatar image

I'm trying to connect to my office desktop (Ubuntu 16.04) using my F24 desktop at home. A few days ago the ability to connect remotely stopped working. The message on the vnc server is:- 12/04/2017 23:09:08 Got connection from client 127.0.0.1 12/04/2017 23:09:08 other clients: 12/04/2017 23:09:08 webSocketsHandshake: invalid client header

I am using vinagre to try to connect using the tunnelling feature.

I have tested the connection with a non-Fedora distribution (Mint) and can connect, so the problem seems to be Fedora specific, so I am wondering what to do next to try to solve the issue.

edit retag flag offensive close merge delete

Comments

what version of VNC you using vinage has a bug with x11vnc server, try connecting using tigervnc.

aeperezt gravatar imageaeperezt ( 2017-04-12 22:28:34 -0600 )edit

I do not know much about VNC, but VNC does not use WebSockets as standard, and the ws:// protocol makes the client do mangling of it's datastream because of HTTP proxy security concerns. So it seems your VNC server expects ws:// connections but gets a standard VNC connection, if this is really the case or why that is I do not know.

Karl Gustavsson gravatar imageKarl Gustavsson ( 2017-04-13 02:15:33 -0600 )edit