Ask Your Question
3

How to get past blank screen during live-dvd boot

asked 2017-04-11 17:24:12 -0600

ds6477 gravatar image

updated 2017-04-12 16:17:17 -0600

I'm trying to install Fedora 25 on a new HP Z440 workstation using the Workstation livedvd and am ending up with a blank screen instead of the desktop environment. The blank screen happens after the white-on-black text-only messages scroll passed on the screen, but before anything graphical comes up (the welcome screen). None of the keyboard shortcuts to get to different consoles change to different consoles. I presume that the boot fails/hangs before any of those resources are available.

The last thing that I see on the screen before it goes black is this:

[ OK ] Reached target sound card

Is there a location or other boot option to find information about what went wrong? I have done some troubleshooting, which I will detail next, but without some sort of error, I'm not sure what is going wrong nor what to do next.

Here is what I have done so far to troubleshoot.

I have tested the livedvd and it checks out. I have used it to install Fedora 25 on another, not-so-new, computer.

This systems does use UEFI and I have tried three different settings offered related to legacy mode and secure boot. I received the same blank screen at the same time with each of the settings. Here were the possible settings:

  • legacy mode, secure boot disabled
  • non-legacy mode, secure boot disabled
  • non-legacy mode, secure boot enabled

I then tried to work through the options given in the graphical troubleshooting page thinking that the graphics card or monitor might be the issue ( https://docs.fedoraproject.org/en-US/... ). I did the following actions (with results):

  • inst.xdriver=vesa: blank screen at same location already noted
  • inst.xdriver=nouveau: blank screen at same location already noted
  • inst.resolution=1024x768: blank screen at same location already noted
  • inst.resolution=1920x1080: scrolling errors right after starting (scrolled too fast to read, but I think I saw messages about pcie)
  • inst.vnc: blank screen at same location already noted (no IP or screen information was displayed)

I then tried text-only mode, and got the blank screen in the same location that I already noted. After that, I tried an older monitor, but got the same results. Unfortunately, I am not able to swap out the graphics card as the new system refuses to POST with the older cards that I have, and there is no video port on the motherboard.

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. I don't know if I can help, but I may be able to eliminate a few possibilities. First, does your graphics card use nVidia, because if not, the nouveau driver won't help. Second, if memory serves, the boot messages tell you what's starting as well as what's finished initializing, meaning that the sound card isn't involved. If you can spot what's in the process of initializing when this happens, that might tell us where to look. Last, since this happens with two monitors, that's not causing this.

sideburns gravatar imagesideburns ( 2017-04-11 19:53:17 -0600 )edit

@sideburns, thank you for the insight. The video card is an nVidia Quadro card. In looking over the boot output that does scroll on the screen, there is a "Starting..." entry that doesn't have a matching "Started..." entry: Starting Switch Root. All other "Starting" or "Stopping" entries have a "Started" or "Stopped" line somewhere else in the boot output. What is the "Starting Switch Root" stage?

ds6477 gravatar imageds6477 ( 2017-04-12 10:39:56 -0600 )edit
1

@steveebey73742, adding "nomodeset" to the linux command line did get me in to the graphical desktop environment. I am currently working through the installation and hopefully the system boots fine after installation. Thank you!

ds6477 gravatar imageds6477 ( 2017-04-12 11:19:24 -0600 )edit

@ds6477, that is the first step, you will need to decide to use rpm or propietarry for your video drivers. I have a geforce 970 and have had good luck on proprietary. I use dkms to update automatically with kernel changes, and the opengl render version is 4.5 so I get decent graphics performance.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-04-12 13:36:58 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-04-12 08:09:00 -0600

SteveEbey73701 gravatar image

updated 2017-04-12 08:09:53 -0600

At grub, hit E, add nomodeset to linux cmdline in front of quiet. That should force a low res graphics mode for you. or just select the troubleshoot entry from the grub menu on the live dvd

edit flag offensive delete link more
1

answered 2017-04-12 16:22:26 -0600

ds6477 gravatar image

updated 2017-04-12 17:20:36 -0600

The solution was to add "nomodeset" to the linuxefi command line in front of quiet. This allowed the live-dvd boot to continue in to the desktop environment and then I could install Fedora 25. Rebooting in to the fresh install did not require the use of any additional kernel parameters. The solution was given by @steveebey73742, but I am not sure how to promote the comment as the solution.

In case it is useful, the graphics card is an Nvidia Quadro M2000.

edit flag offensive delete link more

Comments

Thank you. I am glad it helped, how goes the rest of the setup? I have a 7.1 Soundblaster, Geforce gtx970 so if you need help with anything related to those devices let me know.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-04-12 17:18:53 -0600 )edit

The rest of the installation went without a hitch; that one boot parameter did the trick. For now, I've just got the onboard sound card which seems to work fine, although I'm having some issues getting audio to go out the displayport connection to a speaker-equipped monitor. That'll be something else to play with in my free time.

ds6477 gravatar imageds6477 ( 2017-04-12 17:27:08 -0600 )edit

Which video driver did you go with? Is nomodeset in the boot gub on the hard drive? if so, after you are certain the video driver is working, you can remove it, and should be able to run at maximum supported resolution on your monitor.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-04-12 17:56:53 -0600 )edit

Right now I'm using the rpm drivers (nouveau). It looks like 'nomodeset' is still on my grub linuxefi lines. I'll have to change that when I can reboot. How do I make sure the video driver is working other than the monitor is displaying the graphical environment?

ds6477 gravatar imageds6477 ( 2017-04-14 10:16:40 -0600 )edit

Are you able to adjust resolution on the display? if so, then everything is probably working and the nomodeset can be removed. Having said that, nomodeset may prevent graphics resolution changes, so you might have to remove it first, to test. if it fouls up, you can always put it back.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-04-14 10:35:55 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-04-11 17:21:03 -0600

Seen: 513 times

Last updated: Apr 12 '17