Ask Your Question
1

Problem Installing Fedora 17 on HP Z 220 CMT (SandyBridge Ci5)

asked 2012-09-20 09:40:47 -0500

Navid Shaikh gravatar image

System specs:

Processor: Intel Core i5-3470
Chipset: Intel C216 chipset (looked up, not *very* sure)
RAM: 2x4GB DDR3 @ 1600MHz
HDD: 500GB SATA 3.0 @ 7200RPM

I am trying to install fedora 17 on HP Z220 CMT workstation having Intel HD Graphics 2500, I have faced following two issues:

  1. During installation steps upto creation of partition, the screen was not clear. Screen was blurring, and all the pixels became such zoom that I was unable to read anything about the partition and other stuff (right from beginning). Though I managed to install fedora 17 by looking into the snapshots of fedora installation steps over internet.

  2. Main issues is here: After installation of Fedora 17, when I restarted, it boots up & just before the login screen the screen goes dark, with some random blue-pixels at the top (sometimes with a message, like "oh! something went wrong..... unrecoverable!").

More Context: I've tried SSH'ing to the system & that worked out pretty good. My guess: there is an issue with the graphics-hardware (Intel HD 2500).

Please feed with the valuable solutions, Thank you.

edit retag flag offensive close merge delete

Comments

try it with nomodeset...i was facing the same thing with readon card

Akshay gravatar imageAkshay ( 2012-09-20 12:07:09 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-09-20 10:58:21 -0500

ZenDark gravatar image

Boot the system in text mode.

Edit the grub line adding a "3" at the end of the line and removing rhgb.

After the system has started, login and do a full update, maybe there will be some package that fixes your problems with the graphic card.

If that doesn't work:

[SOLVED] Intel HD 2500 configuration problems

edit flag offensive delete link more
0

answered 2012-09-28 01:47:29 -0500

Navid Shaikh gravatar image

Solution:

Aim: appending 'nomodeset' in kernel option in /etc/default/grub

steps:

1)After Installation of fedora, reboot.(anyhow as I mentioned in question)

2)Point Fedora 17 in grub menu, and press 'E', it will display a window titling "GNU GRUB version 2.00~beta4"

3)go to the line that starts with

linux  /boot/vmlinuz-3.3.4-5......UTF-8 rhgb quiet..

4)erase everything after UTF-8(i.e. rhgb...) and write 3 there. after that line should look like

 linux  /boot/vmlinuz-3.3.4-5......UTF-8  3

5)press f10 and you would be redirected to text console(rather GUI).

6)login there

7)open the file /etc/default/grub and append in the last "nomodeset" in GRUBCMDLINELINUX, after appending it would look

GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True rd.luks=0 LANG=es_ES.UTF-8  KEYTABLE=es rhgb quiet nomodeset"

(append only nomodeset in last, dont modify other parameteres!)

8)save the file, and run this command

grub2-mkconfig -o /boot/grub2/grub.cfg

9)reboot, now graphics should work smooth.

If any problem occurs during these steps, please comment here!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-09-20 09:40:47 -0500

Seen: 1,143 times

Last updated: Sep 28 '12